aspose file tools*
The moose likes Tomcat and the fly likes problem setting up tomcat Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "problem setting up tomcat" Watch "problem setting up tomcat" New topic
Author

problem setting up tomcat

Jon Summers
Greenhorn

Joined: Jul 15, 2003
Posts: 24
Hello,
I finally installed tomcat 5.0.16 from an exe file. Setup was finished. but when i try starting the tomcat from a startup batch file. it gives me a following error:
Out of environment space
Out of environment space
The CATALINA_HOME environment variable is not defined correctly
This environment variable is needed to run this program
All i did was specify JRE and SDK in my classpath and then executed the ".exe" file for windows. Please tell me what im doing wrong..im really stuck on this. Thanks a lot.
Jon Summers
Greenhorn

Joined: Jul 15, 2003
Posts: 24
alrite, i took care of the out of memory envornment..now i get the following error:
The JAVA_HOME environment variable is not defined
This environment variable is needed to run this program
I'm using windows ME..and this is wut my PATH looks:
C:\j2sdk1.4.1_03;.C:\java\j2re\bin\;.;C:\j2sdk1.4.1_03\bin;
Now, im totally stuck..wut am i doing wrong???..any help would be greatly appreciated
Jason Kretzer
Ranch Hand

Joined: May 31, 2001
Posts: 280
I THINK you need to set an environment variable in you autoexec.bat that is JAVA_HOME="Path to Java top level dir"


Jason R. Kretzer<br />Software Engineer<br />System Administrator<br /><a href="http://alia.iwarp.com" target="_blank" rel="nofollow">http://alia.iwarp.com</a>
Carleton Harrison
Greenhorn

Joined: Jan 11, 2004
Posts: 14
Hello !!!
In your file:
C:\AUTOEXEC.BAT
add a line similar to:
SET JAVA_HOME=c:\j2sdk1.4.1_03
(the top level directory of your entire JAVA SDK hierarchy...)
HTH !!!
CH
 
 
subject: problem setting up tomcat