aspose file tools*
The moose likes Tomcat and the fly likes Oracle Tomcat clash Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Oracle Tomcat clash" Watch "Oracle Tomcat clash" New topic
Author

Oracle Tomcat clash

Tony Evans
Ranch Hand

Joined: Jun 29, 2002
Posts: 582
I am running Oracle 9i on my PC which listens in on port 8080.
I have edited server.xml, where ever I saw port 8080 I replaced with 9000.
I have the startup message Starting Coyote HTTP/.1 on port 9000
Last message is server startup in 7791 ms.
I guess this means that Tomcat has started up ok.
Problem is that when I run http\\localhost:9000\index.html I get page cannot be displayed.
Is there a way of debugging any of the scripts to see what happens when I try to run http\\localhost:9000\index.html or will I need to download the source code to complile and run.
Thanks for any Help Tony
Mike Curwen
Ranch Hand

Joined: Feb 20, 2001
Posts: 3695

Do you actually get 'page cannot be displayed'? or is it a 404 error? Do you have friendly error messages turned on in IE ? (if you do, turn them off, you'll be doing yourself a favour!).

If you're literally typing in:
http\\localhost:9000\index.html
1) missing colon
2) use forward slashes
3) there's no such file as 'index.html' under the ROOT context.

what happens when you try:

http://localhost:9000/
Tony Evans
Ranch Hand

Joined: Jun 29, 2002
Posts: 582
Thanks Mike, I was typing the slashes the wrong way,
http://localhost:9000/ returns "The page cannot be displayed:"
The problem is that when I type in http//localhost I find the Oracle Server.
Has establshed a connection therefore I can not use Tomcat.
I have tried to stop TNSLSNR.exe but I get access is denied.
Thanks for any help Tony.
Tony Evans
Ranch Hand

Joined: Jun 29, 2002
Posts: 582
I have used the stop Oracle Apache web server command, which does stop the server. So when I run localhost I get page cannot be displayed.
But I still cant get http://localhost:9000/ to load the Tomcat startup page.
Also the startup message states
Server startup in 10325 ms. Can anyone tellme what this message means.
Thansk for any help
Tony
Tony Evans
Ranch Hand

Joined: Jun 29, 2002
Posts: 582
Using services I have turned all my Oracle applications to manual, and have retarted my PC. This has freeded 8080.
I have set port connection back to 8080, and have run the startup script.
It works now.
Cheers Tony
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Oracle Tomcat clash