This week's book giveaway is in the Clojure forum.
We're giving away four copies of Clojure in Action and have Amit Rathore and Francis Avila on-line!
See this thread for details.
Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Tomcat error

 
shuzo monsoon
Ranch Hand
Posts: 54
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello and can someone help!? I just tried to start my tomcat server and I got this error - -Dsun.io.useCanonCaches=false file not found. The server usually works fine. I dont know what has caused this. Anyone any ideas?!
 
shuzo monsoon
Ranch Hand
Posts: 54
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Its ok now. It turns out I had altered my java environment variable incorrectly.
 
Dave Mere
Ranch Hand
Posts: 37
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm having the same problem! The solutions I've found on the web involve altering my environment settings to the location of the java.exe file in my jdk directory . . . but this doesn't seem to be helping. How exactly did you solve this problem?

Many thanks,

Dave
 
Mike Curwen
Ranch Hand
Posts: 3695
IntelliJ IDE Java Ubuntu
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
on windows, it's sometimes as easy as making sure you use paths with no spaces in their names (since Tomcat uses DOS scripts).
 
Dave Mere
Ranch Hand
Posts: 37
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The problem was actually pretty similar to that Mike.

Required path : C:\j2sdk1.4.2_04\
My path : C:\j2sdk1.4.2_04

Took me 2 hours to figure out I had to add a backslash.
 
I agree. Here's the link: http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic