This week's book giveaway is in the Mac OS forum.
We're giving away four copies of a choice of "Take Control of Upgrading to Yosemite" or "Take Control of Automating Your Mac" and have Joe Kissell on-line!
See this thread for details.
The moose likes Tomcat and the fly likes APACHE+SSL Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Products » Tomcat
Bookmark "APACHE+SSL" Watch "APACHE+SSL" New topic
Author

APACHE+SSL

Abhijeet Gholkar
Greenhorn

Joined: Jun 11, 2002
Posts: 25
Hi guys
Iam trying to configure Apache 2.0.49+SSL (OpenSSL 0.9.7a) on SunOS 5.8
While configuring apache i found the following errors,
====================================================================
1.
configure:10642: checking for SSL_set_state
configure:10699: gcc -o conftest -g -O2 -pthreads -DSOLARIS2=8 -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -L/teams5/home/abhijit/httpd-2.0.43/source/httpd-2.0.49/srclib/apr-util/xml/expat/lib -L/usr/local/ssl/lib -R/usr/local/ssl/lib conftest.c -lssl -lcrypto >&5
Undefinedfirst referenced
symbol in file
SSL_set_state /var/tmp//ccsDjMEg.o
ld: fatal: Symbol referencing errors. No output written to conftest
collect2: ld returned 1 exit status
configure:10705: $? = 1
============================================================
2.
configure:10744: checking for SSL_set_cert_store
configure:10801: gcc -o conftest -g -O2 -pthreads -DSOLARIS2=8 -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -L/teams5/home/abhijit/httpd-2.0.43/source/httpd-2.0.49/srclib/apr-util/xml/expat/lib -L/usr/local/ssl/lib -R/usr/local/ssl/lib conftest.c -lssl -lcrypto >&5
Undefinedfirst referenced
symbol in file
SSL_set_cert_store /var/tmp//ccMdNa8Y.o
ld: fatal: Symbol referencing errors. No output written to conftest
collect2: ld returned 1 exit status
configure:10807: $? = 1
==================================================================
If i ignore this and move forward, i get following error on hitting apachectl startssl
======================================================================
[Fri Apr 16 02:07:16 2004] [crit] [Fri Apr 16 02:07:16 2004] file vhost.c, line 189, assertion "rv == APR_SUCCESS" failed
Abort - core dumped
======================================================================
Iam not sure if the error at apache statup is because of configuration error
Has anybody come across this problem ?
Regards
Raja
 
GeeCON Prague 2014
 
subject: APACHE+SSL