This week's giveaway is in the EJB and other Java EE Technologies forum.
We're giving away four copies of EJB 3 in Action and have Debu Panda, Reza Rahman, Ryan Cuprak, and Michael Remijan on-line!
See this thread for details.
The moose likes Tomcat and the fly likes Problems in deploying application on Tomcat 4 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Problems in deploying application on Tomcat 4" Watch "Problems in deploying application on Tomcat 4" New topic
Author

Problems in deploying application on Tomcat 4

Raju Vemula
Greenhorn

Joined: Apr 29, 2004
Posts: 6
Hi,
I'm facing problems in deploying my application on tomcat 4.
I had moved my project code under /webapps/myapp folder and editted the server.xml file adding in it the <context> tag for my App. And after restarting the server, i could access my login page, but when i enter the login id and click on the submit button, it displays "The page cannot be found", HTTP 404 Not Found page. i couldn't find any errors in the log files too.
Here is the content of the log file:
2004-04-29 08:26:12 WebappLoader[/maputil]: Reloading checks are enabled for this Context
2004-04-29 08:26:13 StandardManager[/maputil]: Seeding random number generator class java.security.SecureRandom
2004-04-29 08:26:14 StandardManager[/maputil]: Seeding of random number generator has been completed
2004-04-29 08:26:14 StandardWrapper[/maputil efault]: Loading container servlet default
2004-04-29 08:26:14 default: init
2004-04-29 08:26:14 StandardWrapper[/maputil:invoker]: Loading container servlet invoker
2004-04-29 08:26:14 invoker: init
could anyone please help me out.
thanX in advance,
raju
Mike Curwen
Ranch Hand

Joined: Feb 20, 2001
Posts: 3695

I see the 'loading invoker', but that doesn't mean it's mapped.

Did you read : Invoker FAQ
Raju Vemula
Greenhorn

Joined: Apr 29, 2004
Posts: 6
i got the solution for my problem. i did not give an entry in a .conf file for my application which actually tells the Apache webserver what to forward to the tomcat application server. thanx anyhow mike.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problems in deploying application on Tomcat 4
 
Similar Threads
Tomcat not behaving:(
Tomcat Access Problem
tomcat can't find index.jsp
Problems with tomcat 4.1.18 - migration from tomcat 3.2.1
cannot open localhost:8080