This week's book giveaway is in the OO, Patterns, UML and Refactoring forum.
We're giving away four copies of Refactoring for Software Design Smells: Managing Technical Debt and have Girish Suryanarayana, Ganesh Samarthyam & Tushar Sharma on-line!
See this thread for details.
The moose likes Tomcat and the fly likes Tomcat application connection problem with RMI Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Products » Tomcat
Bookmark "Tomcat application connection problem with RMI " Watch "Tomcat application connection problem with RMI " New topic
Author

Tomcat application connection problem with RMI

Venkatesh Rajendran
Ranch Hand

Joined: May 17, 2001
Posts: 59
Hi,

I have an application in Tomcat server, from which I am accesing a RMI server, which serves me some data, if I access through RMI default port it returns me the requested data, but if I access through some other port like 2005, it does not. Any one come across such situation, i request you to pass me some information on this.

Following are the set of things I have done to set port, correct me if I am doing wrong.

I am binding the object using following command,

Naming.bind("//12.22.123.232:2005/ServerObj", servObj);

Similarly I am looking up for the same port from client side like,

Naming.lookup("//12.22.123.232:2005/ServerObj");

I am also starting RMI registry to look for the same port only like,

LocateRegistry.createRegistry(2005);

Thanks in advance.

Regards,

Venkat
 
I’ve looked at a lot of different solutions, and in my humble opinion Aspose is the way to go. Here’s the link: http://aspose.com
 
subject: Tomcat application connection problem with RMI
 
It's not a secret anymore!