wood burning stoves 2.0*
The moose likes Tomcat and the fly likes connection timeout. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "connection timeout." Watch "connection timeout." New topic
Author

connection timeout.

Jacek Nabywaniec
Greenhorn

Joined: Aug 16, 2003
Posts: 4
Hi,

I need help with the following error in Catalina.out:

SEVERE: All threads are busy, waiting. Please increase maxThreads or check the servlet status

Looking for an answer on the web, I came across this:

After all the setup, I was able to hammer our server. I discovered two useful things: an error in our logout code, which threw exceptions around 10% of the time, and also discovered that our connection timeout between Apache and Tomcat was set incorrectly. Changing this from 0 to 1000 fixed the dreaded SEVERE: All threads are busy, waiting. Please increase maxThreads or check the servlet status error that I was getting.

However, I cannot find the place where this property exists. I have a server provided by the GlobalServers and I access it through a Web-based Control Panel. Under tomcat4/conf, I see the following files:
server.xml.swp
catalina.policy
jk2.properties
server-noexamples.xml.config
server.xml
status
tomcat-users.xml
tomcat4.conf
web.xml

I checked all of these files and could not find this property. Can someone help?
Angel Dobbs-Sciortino
Ranch Hand

Joined: Sep 10, 2003
Posts: 101
It should be in server.xml as an attribute of the XML element Connector.
Jacek Nabywaniec
Greenhorn

Joined: Aug 16, 2003
Posts: 4
Angel, thanks! I found it.

Here's what I have:

<!-- Define a non-SSL Coyote HTTP/1.1 Connector on port 8080 -->
<Connector className="org.apache.coyote.tomcat4.CoyoteConnector"
port="8080" minProcessors="5" maxProcessors="75"
enableLookups="true" redirectPort="8443"
acceptCount="100" debug="0" connectionTimeout="20000"
useURIValidationHack="false" disableUploadTimeout="true" />


My problem is that when it's a busy day, the tomcat crashes and I need to restart the whole virtual server environment. I guess the problem is that too many users are calling the index servlet at the same time.

What would you recommend that I do? Should I try setting maxProcessors to a higher number or change the connectionTimeout property?
Angel Dobbs-Sciortino
Ranch Hand

Joined: Sep 10, 2003
Posts: 101
I'm not sure, since I haven't had this problem myself. You could try increasing maxProcessors, and maybe increasing the amount of memory you're giving Tomcat.
somkiat puisungnoen
Ranch Hand

Joined: Jul 04, 2003
Posts: 1312
you shoule be use Tomcat + Apache WebServer which it's improve performance of web server.


SCJA,SCJP,SCWCD,SCBCD,SCEA I
Java Developer, Thailand
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: connection timeout.
 
Similar Threads
Tomcat - Increase maxThreads
How to resolve the "All threads (500) are currently busy" issue in Tomcat.
Long running request returns no HTTP response
PLEEEEASE tomcat4.1.12 doesn't start
how to increase max thread size