aspose file tools*
The moose likes Tomcat and the fly likes Problems with Tomcat 5 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Problems with Tomcat 5" Watch "Problems with Tomcat 5" New topic
Author

Problems with Tomcat 5

Eelco den Heijer
Ranch Hand

Joined: Jan 17, 2002
Posts: 61
Hi,

Since a while I'm using Tomcat 5.0.28 to test a number of small web applications. On my WinXP notebook it runs without a problem (but I run it a few hours in a row, it doesn't run for days/ weeks....).

I also put these apps 'live' on box that's hosted by a friend of mine. It runs red hat linux with 2.4 kernel, JVM 1.4.2 (Sun) and Tomcat 5.0.28.
It ran flawlessly for about 10 days. Suddenly all my web apps are unreachable; I logged into the admin app, and all the context entries are gone (for my web apps). Also gone: my Single Sing-On Valve.... The Catalina startup log does not reveal anything. We restarted Tomcat; nothing....
Also; I uploaded a dummy war file in the hot-deploy directory; no response. It's like the whole 'host' entry is dead (all contexts, valves under my host entry).

I also noticed many errors in the admin application (e.g. attributes not being updated/ deleted after a 'Commit Changes').

Hence my question: does anyone here know what the problem might be (I do realize I'm not giving a lot of useful clues, but hey, it's all I've got).

And more general: do you think Tomcat 5 is ready for production?

Any help appreciated,
Eelco

----------


== <br />Rgrds,<br />Eelco<br /> <br />SCJP, SCJD, SCBCD, SCWD, SCEA
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problems with Tomcat 5