GeeCON Prague 2014*
The moose likes Tomcat and the fly likes How to increase the Xmx in Tomcat  4.1.27? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Products » Tomcat
Bookmark "How to increase the Xmx in Tomcat  4.1.27?" Watch "How to increase the Xmx in Tomcat  4.1.27?" New topic
Author

How to increase the Xmx in Tomcat 4.1.27?

sreenivas kup
Greenhorn

Joined: Sep 10, 2004
Posts: 7
Hi all,

Apache 2.0/Tomcat (4.1.27) is throwing OutOfMemoryException when I am trying to export large data to excel. I use my custom Servlet for this purpose on a 1 GB RAM Linux box. I didn't get this kind of problem with Tomcat 3. I don't know how to increase the Xmx.

Could you plz help me to sorting out this problem?

Thanks,
Sreenivas
Mike Curwen
Ranch Hand

Joined: Feb 20, 2001
Posts: 3695

look in catalina.sh. There are notes in there on setting $JAVA_OPTS. You can set various -x parameters using $JAVA_OPTS
satish sathineni
Ranch Hand

Joined: May 03, 2004
Posts: 46
Hi,

U can Increase the JAVA_OPTS value in the Catalina.sh for linux box
Catalina.bat for win box

Open the respective file in the respective text editors

Modify JAVA_OPTS variable value

for Linux Box
export JAVA_OPTS = Xmx256m /// for 256 MB or what ever ur requirement is

for Windows Box
set JAVA_OPTS = Xmx256m


Satish Kumar
 
GeeCON Prague 2014
 
subject: How to increase the Xmx in Tomcat 4.1.27?