GeeCON Prague 2014*
The moose likes Tomcat and the fly likes Configuring Apache as Proxy Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Products » Tomcat
Bookmark "Configuring Apache as Proxy" Watch "Configuring Apache as Proxy" New topic
Author

Configuring Apache as Proxy

Sharang Thorat
Greenhorn

Joined: Dec 07, 2000
Posts: 21
Hi

I am using apache 2.0. I want to set apache as proxy i.e any URL I type in browser should pass thru proxy server. I am using following setting to do that in my http.conf file.

# Proxy Server directives. Uncomment the following lines to
# enable the proxy server:

#
<IfModule mod_proxy.c>
ProxyRequests On

#
<Proxy *>
Order deny,allow
Allow from all
</Proxy>


#
# Enable/disable the handling of HTTP/1.1 "Via:" headers.
# ("Full" adds the server version; "Block" removes all outgoing Via:
#headers)

# Set to one of: Off | On | Full | Block
#
#ProxyVia On


#
# To enable the cache as well, edit and uncomment the following lines:
# (no cacheing without CacheRoot)

#
#CacheRoot "C:/Apache/proxy"
#CacheSize 5
#CacheGcInterval 4
#CacheMaxExpire 24
#CacheLastModifiedFactor 0.1
#CacheDefaultExpire 1
#NoCache a-domain.com another-domain.edu joes.garage-sale.com

</IfModule>
#End of proxy directives.

I changed my browser setting to accept http://localhost:80 as proxy server and port (my apache is listening on port 80 ).

Whenever I type any URL in browser I get following error

You don't have permission to access http://home.netscape.com/bookmark/7_2/home.html on this server.

why my apache is not allowing me to access url.

Sharang
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Configuring Apache as Proxy