wood burning stoves 2.0*
The moose likes Tomcat and the fly likes Deploying with Tomcat5.5 and Eclipse3.0??? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Deploying with Tomcat5.5 and Eclipse3.0???" Watch "Deploying with Tomcat5.5 and Eclipse3.0???" New topic
Author

Deploying with Tomcat5.5 and Eclipse3.0???

newbie awo
Greenhorn

Joined: Feb 09, 2005
Posts: 4
Hi, I'm new at Tomcat/Eclipse/J2EE in general, and I've been trying for a while now to deploy my servlets and Struts/Tapestry applications using Tomcat 5.5 and JDK1.4.2_06. The only pages that ever display are the Tomcat welcome page and servlets that I place in the [TOMCAT_INSTALL]\shared\classes folder. These same servlets never run when I place them in the [TOMCAT_INSTALL]\webapps\ROOT\WEB-INF\classes folder. Even when they do successfully display after copying them to the [TOMCAT_INSTALL]\shared\classes folder, errors are generated in the log files:

SEVERE: invoker: Cannot allocate servlet instance for path /servlet/hello.helloservlet
javax.servlet.ServletException: Error allocating a servlet instance
at org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:729)
at org.apache.catalina.servlets.InvokerServlet.serveRequest(InvokerServlet.java:369)
at org.apache.catalina.servlets.InvokerServlet.doGet(InvokerServlet.java:133)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:689)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:802
~~~~~~~~etc etc.....................~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

The invoker servlet and servlet-mapping tags are uncommented in the conf directory; copied from the web.xml file in this directory:


<servlet>
<servlet-name>invoker</servlet-name>
<servlet-class>
org.apache.catalina.servlets.InvokerServlet
</servlet-class>
<init-param>
<param-name>debug</param-name>
<param-value>0</param-value>
</init-param>
<load-on-startup>2</load-on-startup>
</servlet>
.................
<servlet-mapping>
<servlet-name>invoker</servlet-name>
<url-pattern>/servlet/*</url-pattern>
</servlet-mapping>
...........................................
The Struts and Tapestry applications on the other hand (developed with Eclipse 3.0) just never run.
I don't know what else to do, can anyone help? Thanks
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Deploying with Tomcat5.5 and Eclipse3.0???