aspose file tools*
The moose likes Tomcat and the fly likes Tomcat 5 - startup.sh - Permission Denied Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Tomcat 5 - startup.sh - Permission Denied" Watch "Tomcat 5 - startup.sh - Permission Denied" New topic
Author

Tomcat 5 - startup.sh - Permission Denied

Garrett Smith
Ranch Hand

Joined: Jun 27, 2002
Posts: 401
Hi,

Trying run tc5 on OS X. It's been a while since I've done an install of tomcat.

============================================
g-ss-Computer:~ gs$ sudo start_tc5
/bin/start_tc5: line 3: /development/tc5/bin/startup.sh: Permission denied
============================================

Here's start_tc5 shell:
============================================
export CATALINA_HOME=/development/tc5
export JAVA_HOME=/usr
$CATALINA_HOME/bin/startup.sh
============================================

It looks pretty straightforward.

I even tried changing ownership of the directory:
============================================
g-ss-Computer:~ gs$ chown -R gs /development/tc5
============================================

And
============================================
sh-2.05b# chown -R gs:staff /development/tc5
============================================

I still get the "Permission denied" error.

What causes the "Permission denied" error?


comp.lang.javascript FAQ: http://jibbering.com/faq/
Ben Souther
Sheriff

Joined: Dec 11, 2004
Posts: 13410

Does startup.sh have execute permissions?

Type:
ls -l
from Tomcat's bin directory. You should see the permissions for all the files within.

To give the file execute permissions, type:
chmod 700 startup.sh

That gives the owner of the file read,write, and execute permission for that script.
[ February 12, 2005: Message edited by: Ben Souther ]

Java API J2EE API Servlet Spec JSP Spec How to ask a question... Simple Servlet Examples jsonf
Garrett Smith
Ranch Hand

Joined: Jun 27, 2002
Posts: 401
Thanks. Actually, none of the .sh files were executable.

chmod 700 *.sh

fixed that.

But now it looks like I need to d/l the compatibility package...

Thanks again,


Garrett
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Tomcat 5 - startup.sh - Permission Denied