aspose file tools*
The moose likes Tomcat and the fly likes Tomcat 4 not deploying WARs Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Tomcat 4 not deploying WARs" Watch "Tomcat 4 not deploying WARs" New topic
Author

Tomcat 4 not deploying WARs

levani dvalishvili
Ranch Hand

Joined: Mar 01, 2005
Posts: 99
I am having problem deploying a war file on tomcat4 its a apache module installed with ensim front end CP
I tried all kinds of hacks including adding unpackWARs="true" autoDeploy="true" liveDeploy="true"> within server.xml server.xml.template and server_vwh.xml but it still does not deploy
maybe anyone can help?


SCJP 1.5(Done) SCJA 1.0(Done)<br />SCWCD(in Progress...)
somkiat puisungnoen
Ranch Hand

Joined: Jul 04, 2003
Posts: 1312
if you can't not deploy war file in tomcat4, you can manual extract war file in to webapps directory.


SCJA,SCJP,SCWCD,SCBCD,SCEA I
Java Developer, Thailand
levani dvalishvili
Ranch Hand

Joined: Mar 01, 2005
Posts: 99
manual extraction would not do either but..
I got WARs deploy only way they do is :
if I issue sh shutdown.sh then sh startup.sh command within tomcat4/bin deroctory and then restart tomcat with service tomcat4 restart
I wonder if its the right way to get them deployed?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Tomcat 4 not deploying WARs