File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Tomcat and the fly likes Problem Undeploying  webapps Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Problem Undeploying  webapps" Watch "Problem Undeploying  webapps" New topic
Author

Problem Undeploying webapps

Torrey Rice
Greenhorn

Joined: Mar 06, 2005
Posts: 1
Using: Tomcat 5.5.4, JDK 1.5 Win2000 Server
(Also: Tomcat 5.5.4, OS X Panther 10.3.8 latest JVM)

We have several webapps that are deployed from war files. When attempting to undeploy the webapp using the Tomcat Manager app, the war file gets deleted however the unpacked directory remains. The app does seem to deactivate correctly as any attempt to hit it returns a 503, it�s just that the exploded directory remains. The problem is that I want to deploy an updated version of the webapp but when I use the manager to upload and deploy the new one the changes don�t take effect until a restart when Tomcat presumably checks the unpacked content�s time stamp against the war file. Is there a way to update a webapp deployed from a war file without restarting Tomcat?

I tried setting unpackWARs to false in the server.xml hoping that it would delete the war file when I chose undeploy from the manager and then it would see the new war file when I deployed it and use that, however it appears that Tomcat just unpacks the war file to it�s work directory and runs it from there and doesn�t check the timestamp again until a reboot.

I tried yet another test by setting com_myapp_www to the default webapp in the server.xml file. It looks like this



So now when I hit localhost:8080 it will pull up com_myapp_www. Now the oddity is when I undeploy that app and hit localhost:8080 it still returns the content but the war is removed from the webapps directory (because the content is being pulled from the work directory by Tomcat)� but when I deploy the updated war file and hit localhost:8080 it still shows the old content BUT when I hit localhost:8080/com_myapp_www/ it displays the new content but localhost:8080 is still showing the old.

Does anyone have any suggestions as to what I can do to solve this problem? It would make my life so much easier to be able to deploy a new webapp from a war file and not have to restart Tomcat to see the changes.

Thanks in advance
[ March 07, 2005: Message edited by: Torrey Rice ]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problem Undeploying webapps