• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

http://localhost:8085 is giving page not found error when Tomcat is running

 
Senthil Kumar
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I have started Tomcat (Jakarta-Tomcat 5.0.19) in Windows 2000 and it starts and runs fine( port 8085). But when I try to access the Tomcat home page
with http://localhost:8085/, I am getting page not found error.
I even tried by giving http://127.0.0.1:8085, this also doesnt work either.

Could anyone of you let me know how to solve this problem.

Thanks in Advance,
Siva
 
Rahul Singh Khokhar
Ranch Hand
Posts: 36
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Siva,
Are you sure you have set up the right port (8085 in your case). Check the server.xml to confirm the port.

regards,
Rahul..
 
Rahul Singh Khokhar
Ranch Hand
Posts: 36
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Also, try to load a page from any other context e.g http://localhost:8085/manager/html which should prompt you for the username and password for your tomcat admin account.

If this loads well then the Tomcat installation is all fine and the problem lies with the index page in the Root folder. (This seems unlikely though, because the Tomcat index page comes pre compiled)
 
Stefan Willi
Ranch Hand
Posts: 47
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Do you use a Proxy?

As a I start to work at my actual company, I had the same problem. The cause was, that the configuration of the browser was to use a proxy, also for the localhost.

In this case, you can disable the proxy for the localhost in your connection settings or your favorite browser.

Perhaps, you may have the same problem.

stefan
 
Senthil Kumar
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I have checked the port as well as the Proxy settings. Everything is fine.
But still I am getting the page not found error. Is there anything I need
to do with respect to the browser settings ( I am using IE 5.0).

Let me know.

Thanks,
Siva
 
Rahul Singh Khokhar
Ranch Hand
Posts: 36
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
To check the proxy settings within your IE
Go to Tools -> Internet Options -> Connections -> LAN Settings -> and in there uncheck any proxy server
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic