File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Tomcat and the fly likes Help ! SysDeo strange behavior (V3 and V3.1) Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Help ! SysDeo strange behavior (V3 and V3.1)" Watch "Help ! SysDeo strange behavior (V3 and V3.1)" New topic
Author

Help ! SysDeo strange behavior (V3 and V3.1)

Karen Appleby
Greenhorn

Joined: Aug 18, 2005
Posts: 2
I am having terrible trouble with the Sysdeo plug-in (Tomcat 5.0 and Eclipse 3.0.2). I can create my application and install the plug-in and it all runs just fine (that is the first time). Then I make some arbitrary change like entering a space character, the project rebuilds, and suddenly Tomcat fails with the following error:

java.lang.NoSuchMethodError: javax.servlet.jsp.PageContext.getVariableResolver()Ljavax/servlet/jsp/el/VariableResolver;

Strangely the JSP has not changed, it worked before, there were no path changes, so why the heck can't it find the jar file anymore? I looked at my .tomcatplugin and my .classpath and they have not changed. What could possibly be the problem, and how does SysDeo set the classpath.

I have tried putting every jar file I can think of in the DevLoader class path, all to no avail. In any case the original class path worked fine until I entered that blank space. Seems that I can create the project over again by dragging all of the files into a new project and configuring it for the plug-in, I just can't make any changes. As soon as I make a change DevLoader falls apart. Any ideas?
Karen Appleby
Greenhorn

Joined: Aug 18, 2005
Posts: 2
I have a little more information on this now. It appears that the stop Tomcat action does not do a clean stop under Eclipse. If I shutdown Eclipse, sometimes I have to do this twice, and sometimes Eclipse hangs and I have to kill the process. In any case when I get a clean restart of Eclipse the Tomcat application starts working again. Anyone else having trouble with the stop function of this plug-in?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Help ! SysDeo strange behavior (V3 and V3.1)