wood burning stoves 2.0*
The moose likes Tomcat and the fly likes About Tomcat Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "About Tomcat" Watch "About Tomcat" New topic
Author

About Tomcat

Kannan BLR
Greenhorn

Joined: Mar 01, 2005
Posts: 10
Hi,

I want to set the Envoronment variable in Windows 98.

I had set path & classpath in DOS prompt as,

set path=%path%;D:\jdk1.4\bin
set classpath=%classpath%;D:\jdk1.4\lib

I don't know How to set Java_home & catalina_home in windows 98.

Pls any one guide me. then one more Questions.

In my friend P.C, Some jsp Example is running in tomcat server properly. but servlet program is not working in tomcat server and I can't compile servlet file in DOS Prompt also.
shall I want to set any classpath for servlet?

Pls Kindly clarify my doubts as soon as possible.


Rds,
Kannan.A


Kannan.A<br />kannanmsc@sify.com
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 41096
    
  44
A few points that may help you get started:

- Adding the JDK lib directory to the classpath is not going to do much, because it contains jar files, which have to be added explicitly one by one (unless you're using the lib directory to store your own loose class files, which is not a good idea).

- Setting java_home and catalina_home is no different from setting path and classpath. Either you set them on the command line (as you have done with the others), where you will lose them when you close the window, or more permanently under the extended system settings in the workstation properties (may be named differently on Win98).

- You didn't mention what kind of problem you have compiling servlets, but for every compilation you need to include the referenced classes in your classpath. So in order to compile servlets, you need to include the servlet API jar file, which you'll find in the Tomcat/common/lib directory.

- On an unrelated note, this site has a naming policy, and your displayed name does not conform to it; please correct that.
[ August 22, 2005: Message edited by: Ulf Dittmer ]

Ping & DNS - my free Android networking tools app
vidhyasagar reddy
Ranch Hand

Joined: Jul 05, 2005
Posts: 40
Control panel/system-> advanced->
Environment variables


in user variables
click new and give JAVA_HOME in variable name and drive/jdk1.4 variable value


again click new
give CATALINA_HOME in variable name and drive/tomcat



now you can run the jsps and servlets



if u want to compile servlets in command prompt

u have to set the jar file for compiling servlets


got to command


and use this instruction


set classpath=%classpath%;.; (tomcatfoler)/common/lib/servlet-api.jar
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: About Tomcat
 
Similar Threads
Problem compiling a Java Program
set classpath..
tomcat 5.0.19 startup.... pl help
jakarta tomcat server error
How to set up JSDK2.1 server