File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Tomcat and the fly likes How can I get TomCat5.0.28 use JK1.2 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "How can I get TomCat5.0.28 use JK1.2" Watch "How can I get TomCat5.0.28 use JK1.2" New topic
Author

How can I get TomCat5.0.28 use JK1.2

David Chen
Ranch Hand

Joined: Jan 06, 2002
Posts: 57
Hi, there:

I have problems to integrate TomCat5.0.28 with IIS5 on Win2000. The problem seems that from Apache web site it says JK2 was deprecated ( it's weird to deprecate the higher version of product, isn't it?) and recommended to use JK1.2 ( the latest version is JK1.2.15). However, in TomCat5.0.28 server.xml it seems using JK2 by default like:
--------------------------------------------------------------------
<!-- Define a Coyote/JK2 AJP 1.3 Connector on port 8009 -->
<Connector port="8009"
enableLookups="false" redirectPort="8443" debug="0"
protocol="AJP/1.3" />
Also from log it says:
INFO: JK2: ajp13 listening on /0.0.0.0:8009
---------------------------------------------------------------------

So, my question is: how can I set up TomCat5.0.28 to use JK1.2.15? By the way did anyone get TomCat5.0.28 + JK1.2.15 + IIS 5 working? Could you please share some of your experience?

Thanks a lot in advance, highly appreciated any comments or suggestions.

David
David Chen
Ranch Hand

Joined: Jan 06, 2002
Posts: 57
I tried JK2 today, and it works for me almost immediately. I tried both Shiftomat installer application, which is so impressed, and I tried to configure JK2 step by step myself, both ways work for me just fine and almost immediately. Although JK2 is good enough for our simple application now, I still want to know if anyone get JK1.2 work with Tomcat 5.x and IIS 5. (JK2 was deprecated by Apache).

Thanks a lot in advance
David
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: How can I get TomCat5.0.28 use JK1.2
 
Similar Threads
Tomcat 5.0.28 - Apache 2.0.25 using JK2 Config Error
Invoking Servlet Tomcat 5.5.4
Tomcat 5.5.30 and IIS 5 Configuration problem
tomcat6 and apache
Tomcat Apache connector - beginner's question