aspose file tools*
The moose likes Tomcat and the fly likes Apache 1.3.27 Uninstallation Problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Apache 1.3.27 Uninstallation Problem" Watch "Apache 1.3.27 Uninstallation Problem" New topic
Author

Apache 1.3.27 Uninstallation Problem

Sai Shanker
Greenhorn

Joined: Aug 09, 2004
Posts: 17
Hello Friends,

Here is what i did to uninstall :-

I tried removing apache from another windows xp machine through 'Remote Desktop Connection' program.
I also forgot to stop the apache process before uninstalling/removing it


* removed "apache http server 1.3.27" through "control panel", "Add or Remove Programs".
* deleted the Apache Group folder
* restarted machine
* ran apache_1.3.27-win32-x86-no_src.exe

And i got this error message:

The feature you are trying to use is on a network source that is unavailable.
Click OK to try again or enter an alternate path to a folder containing the installation package 'Apache HTTP Server 1.3.27.msi'
Use Source:
C:\DOCUME~1\Jason\LOCALS~1\Temp\_is44\

* I clicked Yes

and got this message:
The path
C:\DOCUME~1\Jason\LOCALS~1\Temp\_is44\Apache HTTP Server 1.3.27.msi' cannot be found. Verify that you have access to this location and try again, or try to find the installation package 'Apache HTTP Server 1.3.27.msi' in a folder from which you can install the product Apache HTTP Server 1.3.27.

And surely enough I found Apache was still listed in the services page as well as in "Add or Remove Programs".
So I did this:

* Restored the deleted Apache Group folder
* removed "apache http server 1.3.27" again in "Add or Remove Programs".
got the same cannot-find-msi-install-package error msg as above, but the program went away

* at command prompt ran 'apache -u -n Apache Web Server' and it successfully removed the service as well
* delete Apache Group folder
* restart machine

The service was no longer listed, but somehow apache reappeared in the Programs listing.
Tried removing it and restart machine several times but it just wouldn't go away.
I tried running apache_1.3.27-win32-x86-no_src.exe several times before and after removing the program,
but kept getting the same error msg as described above that it couldn't find the .msi install package.

Any help would be greatly appreciated! ;-)


Thankyou.
[ December 19, 2005: Message edited by: Sai Shanker ]
 
 
subject: Apache 1.3.27 Uninstallation Problem