Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JDK 1.4 Tomcat and JDK 1.3 Jserv at the sametime?

 
Clarke Kent
Greenhorn
Posts: 14
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi!

I have an application server that is hosting an existing Servlet that runs on JServ and JDK 1.3..

Im trying to host my own servlet in the same Application Server. BUt instead, I need to use JDK 1.4, so im thinking to just install and use Tomcat instead of the existing Jserv, and that Tomcat will use JDK 1.4. Things might go wrong if I override JDK 1.3, so I need to have a separate JDK 1.4 and JDK 1.3 but still the existing servlet will still run perfectly and my own servlet will run also using JDK 1.4
 
Prabodh Reddy
Greenhorn
Posts: 14
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

Whenver we have JDK 1.4 it has backward compatibility with JDK1.3.
so i think there is no need to have two JDK versions.its enough if we have
JDK1.4 and your servlet class...

Regards
Prabodh Reddy
(Sun certified Java Programmer 1.4 )
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser Redhat VI Editor
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I believe you can run Tomcat up to 5.0 with j2sdk1.3.
Check the documentation for the versions.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic