GeeCON Prague 2014*
The moose likes Tomcat and the fly likes Tomcat Administration link does not work. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Products » Tomcat
Bookmark "Tomcat Administration link does not work." Watch "Tomcat Administration link does not work." New topic
Author

Tomcat Administration link does not work.

Jason Asder
Greenhorn

Joined: Dec 21, 2005
Posts: 2
Installed Tomcat 5. Works. Downloaded admin separately from apache. Put the admin folder in $CATALINA_HOME/server/webapps. However, when I click on the Tomcat Administration link from the Welcome page, it gives me a message saying, "Download and install the admin separately".

NOte, I simply copied the admin folder over to the above mentioned webapps directory. What am I doing wrong and how do I fix it? I am guessing I need to deploy the .war file for the admin utility but I don't see it anywhere. Basically, what do I need to do to get this Tomcat Administration to work properly.

Thanks in advance.
William Brogden
Author and all-around good cowpoke
Rancher

Joined: Mar 22, 2000
Posts: 12792
    
    5
On my Tomcat 5 installations, the ./server/webapps/admin/WEB-INF/lib directory has 5 jar files including catalina-admin.jar that came in the admin.zip collection.
I didn't have to do anything but unzip, create an admin rolename entry in tomcat-users.xml and add the role to one username.
After restarting, there it was.
Bill
Jason Asder
Greenhorn

Joined: Dec 21, 2005
Posts: 2
OK. I'll check my directory and see what I have this weekend. I'll post the results later. Thanks for your response.
 
GeeCON Prague 2014
 
subject: Tomcat Administration link does not work.