aspose file tools*
The moose likes Tomcat and the fly likes Compatability Package for Tomcat5.5? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Reply locked New topic
Author

Compatability Package for Tomcat5.5?

Tauri Valor
Ranch Hand

Joined: Aug 03, 2005
Posts: 166
Hi

Ive been using Sun Application Server to develop webservice for Ldap Operations. I used JDK1.4 to compile my java files. Im trying to run this on Tomcat5.5. I need Compatability Package for tomcat to use my class files which were compiled in JDK1.4.

Did anyone use Compatability Package for Tomcat5.5?

Thanks,
Su Yeu
[ January 29, 2006: Message edited by: Su Yeu ]

A Moment's insight is sometimes worth a Life's experience.
Ben Souther
Sheriff

Joined: Dec 11, 2004
Posts: 13410

You only need the compatibility package if you are trying to run Tomcat 5.5x with a Java 1.4 or lower. If you are running it with Java 1.5, you should be able to handle classes compiled with javac 1.4.


Java API J2EE API Servlet Spec JSP Spec How to ask a question... Simple Servlet Examples jsonf
Tauri Valor
Ranch Hand

Joined: Aug 03, 2005
Posts: 166
You only need the compatibility package if you are trying to run Tomcat 5.5x with a Java 1.4 or lower.


I am trying to run Tomcat5.5.13 with Java1.4. I used compatability package for Tomcat5.5.15(since I couldnt find compatability pack for 5.5.13), but it didnt work out.

Ben any other solution?

Cheers,
Su Yeu
Tina Desai
Ranch Hand

Joined: Mar 13, 2003
Posts: 365
Did you find any solution to this?

I am using tomcat5.5 and its manager page shows VM as 1.5x. The jre I have is 1.5 and still my WARs are running only when I add the patch.

I heard it is needed only if one uses jre1.4. But this is not the behaviour I am experiencing.

Am I missing anything here?

Please help.

Regards,
Tina


Alongwith being a good coder, try to be a good professional as well!
Ben Souther
Sheriff

Joined: Dec 11, 2004
Posts: 13410

I run 5.5 without the compat package with no problems.
What problems are you having?
Arul Elango
Greenhorn

Joined: Oct 09, 2003
Posts: 2
Hi,

You can find the compatability package in:

http://tomcat.apache.org/download-55.cgi

- 5.5.17
|-Binary Distributions
|- JDK 1.4 Compatability package


Arul.
[ August 02, 2006: Message edited by: Arul Elango ]
Ben Souther
Sheriff

Joined: Dec 11, 2004
Posts: 13410

Arul,
This thread is 6 months old.
I'm sure the people involved have move past this issue by now.
 
jQuery in Action, 2nd edition
 
subject: Compatability Package for Tomcat5.5?