This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Tomcat and the fly likes Apache Config Issue Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Apache Config Issue" Watch "Apache Config Issue" New topic
Author

Apache Config Issue

Rob Hunter
Ranch Hand

Joined: Apr 09, 2002
Posts: 815
Hi All,
This has to do a bit with perl and PHP so hopefully someone is knowledgable in either/both if need be. I've set up the cgi-bin as directed but when following the instructions to set up for PHP I can't get PHP scripts to show up in the browser using my computer name as it does fine for Perl scripts in cgi-bin. If I put my PHP scripts in cgi-bin and added an Alias line in Apache's conf file the PHPs seem to work fine then. I wanted to set them up as CGI binaries and also wanted to put them in cgi-bin with my other Perl scripts. So I did the whole AddType, Action, and ScriptAlias lines (hopefully I got them right from memory but just to be clear I did follow a, looked like, creditable doc I got off the web). When I try opening the PHP page again I get PhotoParade pop up saying it does handle PHPs but couldnt open this one. Does anyone in here have any experience with setting up Apache with perl and/or PHP? Thanks.

Rob
 
 
subject: Apache Config Issue
 
Similar Threads
How to make a file executable as CGI process on Apache server ?
final plea - security and applets
Data from servlet in html
JApplet - works on windows not on Linux
Java server - jumping in head-first