Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Tomcat w/ SSL - failing connection w/ Netscape

 
Douglas Kent
Ranch Hand
Posts: 171
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,
I am running Tomcat 5.5 on Windows 2K Server. Have gotten a server certificate, with trust chain in a local keystore file. In the connector element in the server.xml file, the significant attributes are: port="442" clientAuth="true" scheme="https" sslProtocol="SSL". Tomcat starts up just fine, but when I attempt to get the served start page on https, I get a browser message "Netscape 7 and <server_name> cannot communicate securely because they have no common encryption algorithms". Internet Explorer is little better...has anyone out there encountered this?
thanks in advance...
 
Ulf Dittmer
Rancher
Pie
Posts: 42967
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You could try sslProtocol="TLS". Also make sure that the various protocols (SSL2, SSL3 and TLS) are turned on in your browser security settings.
[ February 02, 2006: Message edited by: Ulf Dittmer ]
 
Douglas Kent
Ranch Hand
Posts: 171
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes, have tried setting sslProtocol to "TLS"; also checked the browser settings - every cipher is supported.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic