aspose file tools*
The moose likes Tomcat and the fly likes logs: catalina v. console.log Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "logs: catalina v. console.log" Watch "logs: catalina v. console.log" New topic
Author

logs: catalina v. console.log

Matt Garland
Greenhorn

Joined: Feb 24, 2006
Posts: 8
Hi--

I'm setting up a dev box; unfortunately I'm new to Java, Eclipse, Tomcat, Apache, etc, so bear with me.

I can't get Tomcat to come up in the browser with:

http://localhost:8080-->page not found

The environmental variables are set:

CATALINA_HOME=/Applications/Coding/Tomcat
JAVA_HOME=/Library/Java/Home

(Mac OS X 10.4, Apache2, Tomcat 5.5)

So I went to the logs folder, found catalina, double clicked.

Then TWO windows pop up: an old log (came with download, catalina2005-5-30.log) where catalina is shown to be started and stopped. And a current "console.log," which shows me shutting down and staring up Apache, but not Catalina.

How do I configure/activate current logging for Catalina?

Thanks

P.S. I should say that I DID have Tomcat running at one point...but then I installed these programs:

MAMP (XAMPP for OS X)--started using Apache2 at localhost:8888
Eclipse--Tomcat Sysdeo plugin
Tomcat widget

After that, I lost it...

The current "console.log" show this error for the widget, which I've uninstalled:

2006-02-26 09:45:32.238 DashboardClient[288] /SourceCache/JavaScriptCore/JavaScriptCore-417.8/bindings/objc/WebScriptObject.mm:211:[288] JavaScript exception: Object (result of expression output.split) does not allow calls.

Could this be a port conflict? I don't even know if Tomcat is running, however. I need that log.
Matt Garland
Greenhorn

Joined: Feb 24, 2006
Posts: 8
Uninstalled everything. Reinstalled Tomcat. Ran the bundled OS X Apache server. Set environmental variables. Started up tomcat.

Still nothing.

I searched on my machine for catalina.out and got nothing. It's not under log in the tomcat directory. Not under root/var/log either.
Matt Garland
Greenhorn

Joined: Feb 24, 2006
Posts: 8
so I went back to my environmental variables and rewrote them:

JAVA_HOME=/Library/Java/Home
export JAVA_HOME
CATALINA_HOME=/Applications/Coding/Tomcat
export CATALINA_HOME

I have this in both /etc/profile and ~/.bash_profile.

Still does not work. I need that catalina.out.
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 60053
    
  65

Matt, I don't know how those extra packages are affecting things, but setting up Tomcat on OS X is easier than falling out of bed.

I know you said you tried a re-install, but I'd try again.

This time, make sure that all that old stuff is gone first.

Then, don't bother setting CATALINA_HOME, the shell scripts will handle that at startup.

On my system, since I'm using JDK 1.5, I have JAVA_HOME set to:

JAVA_HOME=/System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Home

I'm not sure why you mentioned Apache at all. It's moot unless you're setting up an Apache->Tomcat connector.

The logs should appear in the Tomcat logs folder.

Once you've got things stable, then I'd try adding your extra stuff one at a time and checking each along the way...
[ February 26, 2006: Message edited by: Bear Bibeault ]

[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
Matt Garland
Greenhorn

Joined: Feb 24, 2006
Posts: 8
thanks bear

OK--I deleted the CATALINA_HOME var, changed the JAVA_HOME one (no alias this time)
OK--uninstalled Eclipse etc
OK--re-downloaded and re-installed Tomcat (I'm embarrassed to say how many times over last couple days)


still doesn't work!

let me describe to you what I'm doing, since I think I'm missing something very, very basic

1) install tomcat
2) set Java variable
3) go to bin, startup.sh, click it, text edit script pops up
4) go to System Preferences>Sharing>tick Personal Web Sharing
5) turn on Firefox and point to localhost, Apache page comes up
6) point Firefox to http://localhost:8080-->page not found
7) go to logs-->there is nothing there
8) go to Activity Monitor, look at all processes, see nothing like Tomcat (though I'm not sure what to look for)


I mentioned using the other Apache server because it was set to port 8888, and I thought it might be taking up 8080, too, but it's long gone

with this install of Tomcat, the only thing I've altered is the permissions on startup.sh and shutdown.bat, so anyone could run them

I really don't think Tomcat is running at all--that's why I'm not getting a log.

What am I missing? Maybe it's the way I'm starting it, do I need to do this one the command line? Assume I'm stupid.

Matt
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: logs: catalina v. console.log
 
Similar Threads
jsp not running in linux
Apache and Tomcat on Mac OS X 10.5?
Jsp not running
Apache SSL Module on Ubuntu
Request to Tomcat from remote machine