aspose file tools*
The moose likes Tomcat and the fly likes Apache not working when accessed with IP address Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Apache not working when accessed with IP address" Watch "Apache not working when accessed with IP address" New topic
Author

Apache not working when accessed with IP address

Prasad Darsi
Greenhorn

Joined: Sep 26, 2004
Posts: 16
Hi,

I have installed apache on windows xp service pack 2. Whenever I am connected to LAN, my D-link router assigns a static ip address '192.168.0.149' to my computer.

I have changed the listen directive in httpd.conf to 'Listen 192.168.0.149:8100'.

I am able to view the default page from the browser if I give 'http://localhost:8100'.

But If I give 'http://192.168.0.149:8100' it is showing the message 'The page cannot be displayed.

Is it a problem with apache ? or router or there are any other settings to be made ?

It would be great if anyone can suggest a solution to this problem..
Thanks in advance,
-Prasad
Kalpesh Patel
Greenhorn

Joined: Apr 10, 2006
Posts: 4
Try updating your host entry in hosts file. I am currently on linux. So, cannot paste the exact path of the file. But, you can look into WINDOWNT/system32/drivers/etc. Please note that this path may be different also.

Add the following entry in this file
192.168.0.149 localhost

Restart apache server.

You should be able to get the page now.

Thanks,
Kalpesh
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61648
    
  67

"Prasad", you have previously been warned on one or more occasions regarding adjusting your display name to meet JavaRanch standards. This is not optional. Please take a look at the JavaRanch Naming Policy and adjust your display name to match it prior to your next post.

Be aware that accounts with invalid display names are removed.

bear
JavaRanch Sheriff
[ April 10, 2006: Message edited by: Bear Bibeault ]

[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
Prasad Darsi
Greenhorn

Joined: Sep 26, 2004
Posts: 16
I changed the entry in "hosts" file as specified.. but it is still giving the same problem.

It worked 10 days back but suddenly it stopped working..

Any settings to be made in router ?
Prasad Darsi
Greenhorn

Joined: Sep 26, 2004
Posts: 16
I think there is problem with Windows xp service pack 2 (SP2).

Because I have installed apache with default configuration on Windows xp professional without SP2 and it is working without any problem. That system is also in the same network and I can access the default page of Apache by using the IP address of the machine..

I also installed Apache with default configuration on another Computer with Windows XP SP2 and it is giving the same problem.

Do I have to uninstall the SP2 from Add/remove programs to solve this problem ?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Apache not working when accessed with IP address