aspose file tools*
The moose likes Tomcat and the fly likes Problem while starting Tomcat 4.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Problem while starting Tomcat 4.1" Watch "Problem while starting Tomcat 4.1" New topic
Author

Problem while starting Tomcat 4.1

Sai Surya
Ranch Hand

Joined: Feb 08, 2006
Posts: 460

Hi,

I installed Tomcat 4.1 (unzipping) and using jdk 1.4. I set all necessary environment variables. Whenever I say "catalina run" to start tomcat the following exception is coming up. I am really upset because of this as I am doing important application development.

Unexpected Signal : EXCEPTION_FLT_STACK_CHECK (0xc0000092) occurred at PC=0xC1D052
Function=[Unknown.]
Library=(N/A)

NOTE: We are unable to locate the function name symbol for the error
just occurred. Please refer to release documentation for possible
reason and solutions.


Current Java thread:

Dynamic libraries:
0x00400000 - 0x00408000 C:\Program Files\Java\j2re1.4.2_03 \bin\java.exe
0x77F40000 - 0x77FEE000 C:\WINDOWS\System32\ntdll.dll
0x77E40000 - 0x77F36000 C:\WINDOWS\system32\kernel32.dll
0x77DA0000 - 0x77E3E000 C:\WINDOWS\system32\ADVAPI32.dll
0x78000000 - 0x78086000 C:\WINDOWS\system32\RPCRT4.dll
0x77D10000 - 0x77D9C000 C:\WINDOWS\system32\USER32.dll
0x77C40000 - 0x77C80000 C:\WINDOWS\system32\GDI32.dll
0x77BE0000 - 0x77C33000 C:\WINDOWS\system32\MSVCRT.dll
0x00370000 - 0x003E3000 C:\DOCUME~1\Youpla\LOCALS~1\Temp\ejc3.tmp
0x77300000 - 0x7738B000 C:\WINDOWS\system32\COMCTL32.DLL
0x71A60000 - 0x71A71000 C:\WINDOWS\system32\MPR.DLL
0x7CCC0000 - 0x7CDE1000 C:\WINDOWS\system32\OLE32.DLL
0x770E0000 - 0x7716B000 C:\WINDOWS\system32\OLEAUT32.DLL
0x71A10000 - 0x71A19000 C:\WINDOWS\System32\WSOCK32.DLL
0x719F0000 - 0x71A04000 C:\WINDOWS\System32\WS2_32.dll
0x719E0000 - 0x719E8000 C:\WINDOWS\System32\WS2HELP.dll
0x08000000 - 0x08138000 C:\Program Files\Java\j2re1.4.2_03\bin\client\jvm.dll
0x76AE0000 - 0x76B0E000 C:\WINDOWS\System32\WINMM.dll
0x10000000 - 0x10007000 C:\Program Files\Java\j2re1.4.2_03\bin\hpi.dll
0x009B0000 - 0x009BE000 C:\Program Files\Java\j2re1.4.2_03\bin\verify.dll
0x009C0000 - 0x009D9000 C:\Program Files\Java\j2re1.4.2_03\bin\java.dll
0x009E0000 - 0x009ED000 C:\Program Files\Java\j2re1.4.2_03\bin\zip.dll
0x02FE0000 - 0x02FEF000 C:\Program Files\Java\j2re1.4.2_03\bin\net.dll
0x71990000 - 0x719CC000 C:\WINDOWS\System32\mswsock.dll
0x76ED0000 - 0x76EF5000 C:\WINDOWS\System32\DNSAPI.dll
0x76F60000 - 0x76F67000 C:\WINDOWS\System32\winrnr.dll
0x76F10000 - 0x76F3D000 C:\WINDOWS\system32\WLDAP32.dll
0x76F70000 - 0x76F75000 C:\WINDOWS\System32\rasadhlp.dll
0x719D0000 - 0x719D8000 C:\WINDOWS\System32\wshtcpip.dll
0x76C40000 - 0x76C62000 C:\WINDOWS\system32\imagehlp.dll


****************
Another exception has been detected while we were handling last error.
Dumping information about last error:
ERROR REPORT FILE = (N/A)
PC = 0x00c1d052
SIGNAL = -1073741678
FUNCTION NAME = (N/A)
OFFSET = 0xFFFFFFFF
LIBRARY NAME = (N/A)
Please check ERROR REPORT FILE for further information, if there is any.
Good bye.

Can somebody suggest me an advice on this?

Thanks in advance,
Surya.


Sai Surya, SCJP 5.0, SCWCD 5.0, IBM 833 834
http://sai-surya-talk.blogspot.com, I believe in Murphy's law.
Jan Groth
Ranch Hand

Joined: Feb 03, 2004
Posts: 456
hi,

just wondering if there are specific reasons to use tomcat 4.x? maybe your important application would benefit from migrating / developing it on tomcat 5.5?

might be worth giving it a try,

regards,
jan
Sai Surya
Ranch Hand

Joined: Feb 08, 2006
Posts: 460

Hi Jan Groth,

Thanks for the reply. I am sure that the problem is NOT because of Tomcat version, the problem is environmental. I would like to know if anybody fixed/benefited from it (I know lot of people faced same problem).

I am still waiting for more responses.

Thanks,
Surya.
Ben Souther
Sheriff

Joined: Dec 11, 2004
Posts: 13410

Originally posted by Sai Surya:
Hi,

I installed Tomcat 4.1 (unzipping) and using jdk 1.4. I set all necessary environment variables.


This doesn't tell us much.
Which ones did you set?
What values did you give to them?
How did you test that they're set correctly?
Why not paste the values in your post so we can verify that they're set correctly?
See:
http://faq.javaranch.com/view?HowToCopyEnvironmentVariablesAndDirectoryStructures
for help with this.

Originally posted by Sai Surya:


Whenever I say "catalina run" to start tomcat the following exception is coming up.


Why aren't you using the startup script in tomcat/bin directory (startup.sh or startup.bat)?

I think Jan's point, which is a good one, is that you're going to be able to get a lot more help if you use a more recent version of Tomcat. Most of the old timers have left Tomcat 4x years ago and a lot of the knowledgeable new comers have never worked with it.

Originally posted by Sai Surya:

(I know lot of people faced same problem).


How do you know this?


Java API J2EE API Servlet Spec JSP Spec How to ask a question... Simple Servlet Examples jsonf
Sai Surya
Ranch Hand

Joined: Feb 08, 2006
Posts: 460

Hi Ben Souther,

- After installing Tomcat 4.1, it ran for a week, after one day, suddenly I started getting the error I mentioned above. So, there is no mistake I did in configuration.

- The reason for not using startup.bat is, when I say startup from the command prompt, a new window is getting displayed and closed immediately, so I was not able to see the error for the first time. Then to see the actual error I used catalina run which starts tomcat in current window, so that I can see the error.

- Using 4.1 version is the recommendation from our client, they are insisting on that, I don't know why

-Surya,
Sai Surya
Ranch Hand

Joined: Feb 08, 2006
Posts: 460

I know lot of people faced this problem, because I googled it
Most people were NOT facing the problem while working with Tomcat, but they are getting the same exception with other applications (JDBC, Weblogic etc).
Ben Souther
Sheriff

Joined: Dec 11, 2004
Posts: 13410

Have you checked the Tomcat log files?
Under {tomcat install}/logs.
Sai Surya
Ranch Hand

Joined: Feb 08, 2006
Posts: 460

The log directory under the Tomcat installation does not creating any log files. Everytime when I do fresh install (unzipping) of Tomcat, it is working fine for few days, and then the same problem arising.

I remeber, this problem was started when I installed Netbeans IDE 5.0 which I got for free from Netbeans web site. Is there any possibility that, netbeans eating up my JVM memory? I tried uninstalling netbeans also, still problem is there.

Can anybody help me on this?

-- Surya
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Problem while starting Tomcat 4.1