aspose file tools*
The moose likes Tomcat and the fly likes setting jsp compiler Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "setting jsp compiler" Watch "setting jsp compiler" New topic
Author

setting jsp compiler

achayya matta
Ranch Hand

Joined: Oct 27, 2005
Posts: 111
hello all,
i am using tomcat 5.5.12 and java 1.5. One of my jsp uses some "generic" stuff from java 1.5 .When i ran my application , the jsp file in which the generic stuff is included,showing error.
Then i did add the following lines to my web.xml which is somewhere in tomcat installation directory.
<init-param>
<param-name>compilerSourceVM</param-name>
<param-value>1.5</param-value>
</init-param>
<init-param>
<param-name>compilerTargetVM</param-name>
<param-value>1.5</param-value>
</init-param>
But its showing the same error. Can anyone clarify me please? What to do?

Regards
ashok
Ray Stojonic
Ranch Hand

Joined: Aug 08, 2003
Posts: 326
Originally posted by ashok reddy devaram:
But its showing the same error. Can anyone clarify me please? What to do?
Not without seeing the offending code and the error text.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: setting jsp compiler
 
Similar Threads
Compiler error on new type of for loop in 1.5
mapping all jsps to single servlets init parameters
Problem in web.xml
Combining two different struts modules of a big application
Jboss4.2 with Eclipse 3.3 - Page does not refresh