• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Tomcat takes heaps of time to start

 
jack nick
Ranch Hand
Posts: 96
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello all,

I have run into a real strange problem with Tomcat. We are deploying an application into the Tomcat server and this works just fine on all the environments we have used till lately.

On a certain box using pretty much the same setup (hardware and software) as always tomcat serves the first page after a long time for the same application as above. Once this first page is served the application works just fine after that.

Has anybody come accross a situation like this? If so any feedback on what is happening would be great. The WAR file has got the JSPs already precompiled.

Cheers
Jack
 
Stu Thompson
Hooplehead
Ranch Hand
Posts: 136
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Jack,

Do the log files show you anything interesting? Like a large amount of time between to discrete entries?

Also, which TC version.

Stu
 
William Brogden
Author and all-around good cowpoke
Rancher
Posts: 13055
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The first question that occurs to me is "how many other applications are hosted on the server?"
The last "as distributed" Tomcat install I did takes a long time to start because of all the applications it contains.

Bill
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic