This week's book giveaway is in the Clojure forum.
We're giving away four copies of Clojure in Action and have Amit Rathore and Francis Avila on-line!
See this thread for details.
Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Could not reserve enough space for object heap

 
Nancy Dawson
Greenhorn
Posts: 13
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am having problem starting my tomcat , Pls the errors are

"Error occurred during initialization of VM
Could not reserve enough space for object heap
Could not create the Java virtual machine."
 
Scott Johnson
Ranch Hand
Posts: 518
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
First shutdown non-essential applications to free some memory.

If that doesn't work, look in the Tomcat conf directory and open the workers2.properties.

Under the [vm:] section, post the parameters so we can see how you've configured Tomcat.

Do you see a parameter like "OPT=-Xmn???M" ? Change the number to a smaller value and try starting Tomcat again.

(I'm assuming you are using Tomcat 5.5, if not the conf file may be different.)
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser Redhat VI Editor
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
How did you install Tomcat?
How do you start/stop Tomcat?



If that doesn't work, look in the Tomcat conf directory and open the workers2.properties.

Unless she's using a connector (For Apache HTTPD or IIS) she probably doesn't have a workers2.properties file.
 
Nancy Dawson
Greenhorn
Posts: 13
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Ben Souther:
How did you install Tomcat?
How do you start/stop Tomcat?




Unless she's using a connector (For Apache HTTPD or IIS) she probably doesn't have a workers2.properties file.


I installed tomcat by unzipping the apache file i downloaded

I am starting tomcat by using ./startup.sh

Stopping by using ./shutdown.sh
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser Redhat VI Editor
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
OK, (with Windows, altering the heap settings is different depening on whether you've installed as a service or not), you're on *nix..

You can increase the heap space settings by adding the following line to your {tomcat install}/conf/catalina.sh file (in bold):


Xms is the initial heap size.
Xmx is the max heap size.

By default the JVM uses 64M which may not be enough for your app.
[ October 04, 2006: Message edited by: Ben Souther ]
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser Redhat VI Editor
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Also, does your machine have enough ram to run Tomcat?
 
Nancy Dawson
Greenhorn
Posts: 13
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Ben Souther:
Also, does your machine have enough ram to run Tomcat?


Its a Red Hat Linux 4 with 256MB of Memory
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser Redhat VI Editor
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That's not a lot.
Are you running XWindows too?

The free command will tell you what you've got available:


The -m switch will cause the output to be displayed in megabytes.
 
I agree. Here's the link: http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic