Win a copy of Learn Spring Security (video course) this week in the Spring forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

The requested URL could not be retrieved : connection failed (111) connection refuse

 
abhijeet srivastava
Greenhorn
Posts: 26
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all!

I have Tomcat 5.5.17 and set JAVA_home and path variables.
But on testing http://localhost:8080 in url it shows error-

ERROR
The requested URL could not be retrieved

------------------------------------------------------

While trying to retrieve the URL: http://localhost:8080/

The following error was encountered:

Connection Failed
The system returned:

(111) Connection refusedThe remote host or network may be down. Please try the request again.

Your cache administrator is root.



------------------------------------------------------------------

Generated Fri, 03 Nov 2006 06:51:31 GMT by 202.54.99.2 (squid/2.5.STABLE9)


Whats wrong???
 
pawank gupta
Ranch Hand
Posts: 34
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
first check your server started properly or not. if yes then check it via http://127.0.0.1:8080 may be your server.xml file not set with localhost, or your host mapping is not done in system file i.e. /system32/ect/host
 
Adeel Ansari
Ranch Hand
Posts: 2874
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
May be your server is not running on that particular port or not running at all. KIndly see the server logs after starting the server.
 
Muhammad Saifuddin
Ranch Hand
Posts: 1324
Android Java Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
First try using http://127.0.0.1:8080

If that works then you do disable your proxy option in your IE go to Tools -> Internet Options -> Connection tab then Lan setting and disable it.

Hope it helps you.
 
abhijeet srivastava
Greenhorn
Posts: 26
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes it is working with http://127.0.0.1:8080 and not with http://localhost:8080.

But when i am disabling proxy option in
IE->Tools -> Internet Options -> Connection tab

it works fine with http://localhost:8080 also.

Can you explain it??
 
Adeel Ansari
Ranch Hand
Posts: 2874
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Even I dont know why it happens to IE after an incertain amount of time. But I found it too. Once it made me to use my local LAN IP instead of localhost or 127.0.0.1.

- Re-intallation might help

What are you getting on enabling the proxy after had it working fine once while proxy is disabled?
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic