aspose file tools*
The moose likes Tomcat and the fly likes Tomcat 5.5 Login Problem in Firefox Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Tomcat 5.5 Login Problem in Firefox" Watch "Tomcat 5.5 Login Problem in Firefox" New topic
Author

Tomcat 5.5 Login Problem in Firefox

Jeff Pollet
Ranch Hand

Joined: Jul 20, 2005
Posts: 49
I recently upgraded our container from Tomcat 4.x to Tomcat 5.5.20. Everything now seems to be working fine (thanks to some help from the javaranchers!) but now I have noticed a problem during the login process--and here's the strange thing: The problem only occurs in Firefox 2.0, not in IE6!

I'm using the the j_security_check form action, j_username and j_password type of authentication. So, when the user goes to the index.html page, she gets redirected to a login.jsp. After logging in, she is then redirected back to index.html, if the login is correct. The user's session ends if it times out, or if she closes the browser window.

But here's what's happening in Firefox:
1. User is redirected to the login page (so far so good).
2. Correct login is entered, but, instead of a redirect, the page stays exactly the same.
3. If, at this point, the user enters the index.html url, she'll be taken to that page as if she had logged in correctly.
4. If, at this point, the user tries to login again, the following familiar error crops up:

5. If, at this point, the user enters the index.html url into the browser, she is redirected as if she has logged in correctly.

So, obviously, the login is *working* on some level, but the user isn't being redirected to the index page. Again, this is only happening in Firefox, not in IE6.

Furthermore, Firefox doesn't seem to be stopping the session if she just closes the browser window (rather than logging out on our logout screen). Again, IE6 doesn't have this problem. According to the tomcat logs, the login in occurring just as it does for IE...there isn't an output to the log when the redirect happens in either case, so it's hard to tell what's going wrong.

I know this is a sort of vague problem, but has anybody else had problems with Firefox in this way?


newbie, please be gentle.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Tomcat 5.5 Login Problem in Firefox