This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes Tomcat and the fly likes Problem with Tomcat Deployment with Eclipse 3.2 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Problem with Tomcat Deployment with Eclipse 3.2" Watch "Problem with Tomcat Deployment with Eclipse 3.2" New topic
Author

Problem with Tomcat Deployment with Eclipse 3.2

Micheal John
Ranch Hand

Joined: Nov 01, 2006
Posts: 344
I am just trying a sample MVC application in Spring using Eclipse IDE 3.2. While I started the tomcat thru' eclipse, I am encountering following errors:

But If I am not using Eclipse IDE and I manually created all the folders under tomcat\webapps\SpringMVC folder..it's working properly..

And in my eclipse, I ahve set the classpath for servlet-api.jar and all required jar files..

Is there any proble in my IDE..?

What will be reason for "java.lang.ClassNotFoundException: org.apache.catalina.servlets.CGIServlet"





Micheal John
SCJP 1.4 (86%), SCWCD 1.4 (86%), SCBCD 1.3 (85%), SCDJWS (Just Started...) - Satisfaction Lies in Our EFFORT, Not in the ATTAINMENT
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Problem with Tomcat Deployment with Eclipse 3.2
 
Similar Threads
Communication link failure: error when satarting tomcat
Axis Webservice deployment exception
Parser error when deploying web app in to Tomcat 5.5
i get NoClassDefFoundError : javax / el / ELException
Cannot retrieve mapping for action /