wood burning stoves 2.0*
The moose likes Tomcat and the fly likes Filter Not Found in new deployment Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCA/OCP Java SE 7 Programmer I & II Study Guide this week in the OCPJP forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Filter Not Found in new deployment" Watch "Filter Not Found in new deployment" New topic
Author

Filter Not Found in new deployment

Allen Williams
Ranch Hand

Joined: Sep 04, 2006
Posts: 136
I have a development machine that everything works find on, and I'm trying to deploy to a production machine, and for some reason it's not finding my filter. The fact that it *knows* about the filter indicates (well, at least, I think it indicates) that it found the web app and associated directories. The public URL is http://www.infoisland.net, which points to /var/www/infoisland in the file system.

On the apache side, here's the apache host entry:



and here's the mod_jk configuration:



On the tomcat side, here's the server.xml section:



And, on the app side, here's the web.xml entry for the filter:



and here's the directory listing of the WEB-INF/classes directory (directly under the /var/www/infoisland directory):



and here is the WEB-INF/classes/infoisland listing, showing the CheckUser class:



And, lastly, here is the output of tomcat, throwing an exception because it can't find CheckUser:


I have also tried putting a infoisland.jar file in the WEB-INF/lib directory, with exactly the same results.

TIA,
Allen


-------<br />Thanks & regards,<br />anw
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Filter Not Found in new deployment