File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Tomcat and the fly likes Tomcat Locale Problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Tomcat Locale Problem" Watch "Tomcat Locale Problem" New topic

Tomcat Locale Problem

Sultan Khadar
Ranch Hand

Joined: Sep 12, 2006
Posts: 75
Hi Friends,
I am facing one problem regarding Tomcat Locale.I am using Tomcat 5.5.23 and Eclipse 3.2.My system's locale has been changed from en-us to Japanese for my project requirement.But, whenever i am starting Tomcat the console is starting in Japanese.All the Error messages are being displayed in Japaneses . I want to see the Tomcat console in en-us, without changing the system Locale.Please help me to solve this problem.

Thanks in advance.
Jaikiran Pai

Joined: Jul 20, 2005
Posts: 10441

Try this:

If you are using windows, in catalina.bat file modify the following line to include, 2 additional arguments (-Duser.language and -Duser.region)

For Unix, change to add those 2 parameters.

[My Blog] [JavaRanch Journal]
Sultan Khadar
Ranch Hand

Joined: Sep 12, 2006
Posts: 75
Hi Jai,
Thanks for Reply. Actually I am using Two Tomcat Servers. Tomcat 5.5.9 for My Project in Eclipse 3.2.1 For which the System Locale is set to Japanese and Tomcat 5.5.23 for My Practice in Eclipse 3.2.2 Versions .The CATALINA_HOME and CATALINA_BASE are set to the Tomcat 5.5.9 Version.

In Eclipse 3.2.2 , I am configuring Tomcat 5.5.23 and setting the CATALINA_HOME to the root directory, i.e c:\Apache Tomcat 5.5.23. But Still I am getting the console in Japanese language.

I have done the modifications suggested by you to the catalina.bat file of Tomcat 5.5.23 but it is not worked.Kindly tell me any possible solution, if there. Sorry for not posting the Problem in detail in my first post.

I agree. Here's the link:
subject: Tomcat Locale Problem
It's not a secret anymore!