This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Tomcat and the fly likes How do I enable JNDI Realm log messages? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "How do I enable JNDI Realm log messages?" Watch "How do I enable JNDI Realm log messages?" New topic
Author

How do I enable JNDI Realm log messages?

Wally Hartshorn
Ranch Hand

Joined: Jan 30, 2003
Posts: 77
I'm trying to use JNDI Realm for the first time and I think I'm pretty close. It allows me to login, authenticating me to our LDAP server, but then I am denied access because it thinks I don't have the right roles. I don't know whether my role search is configured improperly or whether I'm specifying the role incorrectly or what.

Presumably the thing to do would be to check the log to see what sort of problem it has encountered, but I'm unable to figure out how to enable logging of JNDI Realm messages.

In my webapp's context.xml, I have:


Every example I've seen has that 'debug="99"', but I've never seen an explanation of what it actually does. Does that turn on debug log message? Or turn them off? I've tried changing it to other values (1 and 0), but have seen no change in behavior.

My log4j.properties file looks like this:


Do I need to add/change a line in there to enable logging of JNDI Realm messages?


Wally Hartshorn
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: How do I enable JNDI Realm log messages?
 
Similar Threads
Configure JNDI Realm
Tomcat 7.0.20 authentication w/ LDAP
HTTP 403 for authenticated users - FIXED
JNDI Realm to authenticate to ADS
Domino Authorisation using groups