• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

error in isapi.log - running iis 6 tomcat 4.12 newest JK

 
Rasmus Munk Jensen
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi

A couple of times each day (doesn't seems to be any pattern to when or why) i get this error in the log

[Sat Jul 14 20:46:23 2007] [5336:5144] [error] jk_ajp_common.c (1953): (worker1) Connecting to tomcat failed. Tomcat is probably not started or is listening on the wrong port
[Sat Jul 14 20:46:23 2007] [5336:5144] [error] jk_isapi_plugin.c (1499): service() failed with http error 503

Sometimes I just see the error one time, and the system continues on afterwards. Sometimes the error repeats itself (everytime a request is send to the connector). I know that the tomcat is running fine, as requests can be made to 8080 without problems.

Has anyone an idea as to why this happens?

Thanks,

RAsmus
 
William Brogden
Author and all-around good cowpoke
Rancher
Posts: 13058
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
How much load does this system have? Is it possible that all Tomcat processing Threads are busy and the connection is refused?

The number of Threads is set in the Connector element of server.xml file.

You can use the manager interface to get information on the number of Threads in use, etc - if you have the manager app installed.

Bill
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic