wood burning stoves 2.0*
The moose likes Tomcat and the fly likes Lost sessions when using Apache + Tomcat + mod_jk Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Lost sessions when using Apache + Tomcat + mod_jk" Watch "Lost sessions when using Apache + Tomcat + mod_jk" New topic
Author

Lost sessions when using Apache + Tomcat + mod_jk

Marco Ehrentreich
best scout
Bartender

Joined: Mar 07, 2007
Posts: 1282

Hi guys!

Once again I need your help. I'm trying to set up Tomcat behind Apache with mod_jk. So far everything seemed to work fine. But at a closer look i discovered problems with session cookies respectively encoded URLs. I've tested this with Firefox and Konqueror and sometimes Tomcat seems to recognize existing sessions. The manager application from the Tomcat distributions works fine but the admin application and an own little test application are still making trouble.

In the config of mod_jk I have the following mappings to my AJP connector:



Basically this configuration is working except for the sessions. A look in the manager frontend tells me that every click on my reload button in the browser creates a new session. Perhaps I should mention that I'm NOT using any load balancing feature.

I'm using a Gentoo system with the following versions:

Apache 2.0.58-r2
Tomcat 5.5.23-r1
mod_jk 1.2.24

Has anyone experienced the same problems? Is something wrong with my config or perhaps should I use a different solution to connect Apache and Tomcat?

Thanks for your help!

Marco
 
Consider Paul's rocket mass heater.
 
subject: Lost sessions when using Apache + Tomcat + mod_jk