• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Can Tomcat 6 run on JDK 1.4?

 
Bruce Jin
Ranch Hand
Posts: 672
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Many iSeries (AS400) boxes only have JDK 1.4 installed. Is there a way to run Tomcat 6 on JDK 1.4?
Thanks
 
Jeff Genender
author
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I don't believe so. You are stuck with going with Java5 or higher. You *might* be able to do something crazy wth RetroWeaver:

http://retroweaver.sourceforge.net/

But I think that would be a significant effort for you.
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser Redhat VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Tomcat 5.5 has an optional compat library that allow it to be run with a 1.4 JRE. Version 6 requires Java 5.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic