File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Tomcat and the fly likes Tomcat installation problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Tomcat installation problem" Watch "Tomcat installation problem" New topic
Author

Tomcat installation problem

Piotrus Kowalsky
Greenhorn

Joined: Apr 29, 2007
Posts: 6
Hi, I'm trying to install tomcat 6 on x64-86 linux. I downloaded core tomcat package, then I unpacked it. Server starts with no error messages (using $CATALINA_HOME/bin/startup.sh). Everything seems to be ok, but , I can't to connect to the welcome page . I've checked if tomcat ports are in use (netstat -ln), but only my server after start is listening.
I'm using custom port, but I've also tested 8080 with no positive results. It can't be firewall problem, I've run run my old simple server program, and I can connect to it, without any problems. But tomcat still doesn't work .

In catalina.log:


localhost.log


What is going one? Please help me!!
[ November 28, 2007: Message edited by: Piotrus Kowalsky ]
Craig Jackson
Ranch Hand

Joined: Mar 19, 2002
Posts: 405
What port are you using to connect to tomcat locally?

Piotrus Kowalsky
Greenhorn

Joined: Apr 29, 2007
Posts: 6
I've tried to start tomcat on default ports 8080 - I can't connect. I've also tested other ports (11000, etc). Each port is open and not used. After tomcat starts, netstat shows that serwer is listening, but I can't connect.

I've tested all these ports, other services (for example simple echo programs) can use them without any problems
Piotrus Kowalsky
Greenhorn

Joined: Apr 29, 2007
Posts: 6
More info, after shutdown I've got fallowing error:
 
Consider Paul's rocket mass heater.
 
subject: Tomcat installation problem
 
Similar Threads
org.apache.catalina.connector.Connector pause SEVERE: Protocol handler pause failed
Tomcat Native library not found
is not available
Tomcat Configuration -Help pls
can we confuse container by giving wrolg ltd location for a perticular uri