Win a copy of Mesos in Action this week in the Cloud/Virtualizaton forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Tomcat6.0 startup!! IllegalArgumentException

 
palla sridhar
Ranch Hand
Posts: 111
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi!
I'm using Tomcat6.0.14 and SysdeoTomcat plugin in Eclipse 3.3.
Some time back, when i ran Tomcat from Eclipse, it worked fine..
I installed Tomcat as a service.

I also have Netbeans6.0 installed, which requires Tomcat to be installed as an archive.

So now,i've two Netbeans instances (6.0 only) in two different locations.
My CATALINA_HOME is the TOMCAT archive home.

I get the following error when i run Tomcat SERVICE from Eclipse.



Previosly i used D:\NetBeansPrj as a folder for NetBeans development.
Now i dont have that directory.
Tomcat service server is running fine, even with the IllegalArgumentException.

I checked starting a web-application and that's also running fine..

But can anybody help, why i'm getting this IllegalArgumentException and how can i remove this error on start-up??


[Jesper Young: Edited for readability]
[ January 02, 2008: Message edited by: Jesper Young ]
 
Jesper de Jong
Java Cowboy
Saloon Keeper
Posts: 15288
39
Android IntelliJ IDE Java Scala Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You have a reference to D:\NetBeansPrj somewhere in your Tomcat configuration. Look through the Tomcat configuration files (especially server.xml) and make sure to remove references to that directory.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic