wood burning stoves 2.0*
The moose likes Tomcat and the fly likes Tomcat6.0 startup!! IllegalArgumentException Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Tomcat6.0 startup!! IllegalArgumentException" Watch "Tomcat6.0 startup!! IllegalArgumentException" New topic
Author

Tomcat6.0 startup!! IllegalArgumentException

palla sridhar
Ranch Hand

Joined: Oct 15, 2007
Posts: 111
Hi!
I'm using Tomcat6.0.14 and SysdeoTomcat plugin in Eclipse 3.3.
Some time back, when i ran Tomcat from Eclipse, it worked fine..
I installed Tomcat as a service.

I also have Netbeans6.0 installed, which requires Tomcat to be installed as an archive.

So now,i've two Netbeans instances (6.0 only) in two different locations.
My CATALINA_HOME is the TOMCAT archive home.

I get the following error when i run Tomcat SERVICE from Eclipse.



Previosly i used D:\NetBeansPrj as a folder for NetBeans development.
Now i dont have that directory.
Tomcat service server is running fine, even with the IllegalArgumentException.

I checked starting a web-application and that's also running fine..

But can anybody help, why i'm getting this IllegalArgumentException and how can i remove this error on start-up??


[Jesper Young: Edited for readability]
[ January 02, 2008: Message edited by: Jesper Young ]

Thanks and Regards,
[url]www.techlikes.com[/url]
*Nothing is CONSTANT in life, except CHANGE*
Jesper de Jong
Java Cowboy
Saloon Keeper

Joined: Aug 16, 2005
Posts: 14074
    
  16

You have a reference to D:\NetBeansPrj somewhere in your Tomcat configuration. Look through the Tomcat configuration files (especially server.xml) and make sure to remove references to that directory.


Java Beginners FAQ - JavaRanch SCJP FAQ - The Java Tutorial - Java SE 7 API documentation
Scala Notes - My blog about Scala
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Tomcat6.0 startup!! IllegalArgumentException
 
Similar Threads
Tomcat init ValidatorPlugin and TilesPlugin twice -- why?
error in struts
SEVERE: Error initializing endpoint
Filters and web.xml problem + Eclipse
How to user Struts Tags in a WebApplication