File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Tomcat and the fly likes Tomcat manager not showing my index.html Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Tomcat manager not showing my index.html" Watch "Tomcat manager not showing my index.html" New topic
Author

Tomcat manager not showing my index.html

Vaishali Paramane
Ranch Hand

Joined: Mar 05, 2007
Posts: 106
Hi
I added new folder 'email' in webapps with simple servlet with web.xml. but its not showing in tomcat manager.
If I added any folder it showing sometimes but if i change folder name then it sometimes showing sometimes not showing in tomcat manager.
Can any one know this problem?
I am using tomcat6.0.2.

Thanks
Vaishali


SCJP, SCJD
Preparing for SCWCD
Ben Souther
Sheriff

Joined: Dec 11, 2004
Posts: 13410

Are you seeing any errors in the Tomcat logs?
Could it be that you're checking the Tomcat manager before it has a chance to deploy the new app?

Do you have autoDeploy turned off?


Java API J2EE API Servlet Spec JSP Spec How to ask a question... Simple Servlet Examples jsonf
kalyan godavarthy
Greenhorn

Joined: Jan 14, 2008
Posts: 5
Hello Vaishali
You are deploying an war file which is exploding into an folder or directly deploying an folder, and about the webapp folder hierarchy make sure it follows the
Tomcat installation directory/webapps/your web folder/ *.html+*.jsp+web-inf folder/web.xml+[in a folder]/*.class
and web.xml should have an welcome-file list tag with index.html which will be the default one, so you should have index.html in your web folder
thanks


live and let livE
Ben Souther
Sheriff

Joined: Dec 11, 2004
Posts: 13410

KALYAN ANAND,

How's about doing our eyes a favor and fixing your screen name so it isn't typed with all upper case letters?
 
jQuery in Action, 2nd edition
 
subject: Tomcat manager not showing my index.html