aspose file tools*
The moose likes Tomcat and the fly likes Unable to run Apache 2.x Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Unable to run Apache 2.x" Watch "Unable to run Apache 2.x" New topic
Author

Unable to run Apache 2.x

Nidhi Jain
Ranch Hand

Joined: Mar 26, 2006
Posts: 31
After lots of installation and uninstall I am not able to run Apache server.

And find it very difficult.

My machine is running on Windows 2003 server with IIS 6.0.

But I'm not able to run the Apache. Windows System Event Log says: The Apache Tomcat service terminated with service-specific error 0 (0x0).

A couple of times I have uninstalled Apache and installed the same still
have the same issue.

Please let me know the workaround.

Thank you,

Regards,
Nidhi
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 42282
    
  64
The error message mentions "Apache Tomcat", but you're asking about "Apache 2.x", by which I assume you mean Apache httpd?

Since you mention also running IIS, make sure they don't try to use the same port.


Ping & DNS - my free Android networking tools app
Nidhi Jain
Ranch Hand

Joined: Mar 26, 2006
Posts: 31
But my main problem is Service is not running....Is there any system requiremnt before to install Appache 2.x?
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 42282
    
  64
Yes, but which service is that: Apache httpd or Apache Tomcat? Are you trying to install both at the same time?

Are you certain there are no port conflicts?
Nidhi Jain
Ranch Hand

Joined: Mar 26, 2006
Posts: 31
I am talking about apache htpd.Yes only IIS is running on 80 port.
Nidhi Jain
Ranch Hand

Joined: Mar 26, 2006
Posts: 31
and I have installed the JDK1.5 also...Is there any other system requirement?
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 42282
    
  64
So how do you know httpd is not running? The error message is about Tomcat, which may or may not have anything to do with this. Which port is httpd configured for?
Nidhi Jain
Ranch Hand

Joined: Mar 26, 2006
Posts: 31
I am trying to Install the Apache web server,I didn't set any port for httpd.In my system tray Apache monitor is displayed but with red dot,that means no service is installed, So i checked the system log file.Will you please tell me how should i install the Appache on windows 2003 and IIS 6 and jdk1.5.

I am not able to install.

Hope you understand my problem now.

Thanks,
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 42282
    
  64
If httpd is displayed in the system tray, then it would seem that it is installed. It may not be running due to any number of problems, though.

E.g., if you didn't specify any port during the installation it's perfectly possibly that it's trying to use the same port IIS is already running on, isn't it? That would prevent httpd from running. Try shutting down IIS and see if you can start httpd then.

I'd also investigate why it's displaying a message about Apache Tomcat in the log if you're actually trying to run Apache httpd. Make sure httpd isn't failing because it's trying to start Tomcat and that's not working.

Whether a JDK is installed is irrelevant for running Apache httpd itself. It neither contains nor uses Java.
Nidhi Jain
Ranch Hand

Joined: Mar 26, 2006
Posts: 31
During Installation I checked on the option of for all user ,on port 80, as service recommended.But now I have changed it-by made some changes in "httpd.conf" file,But it's not working again.
Nidhi Jain
Ranch Hand

Joined: Mar 26, 2006
Posts: 31
Thanks for your help..now it's working
 
wood burning stoves
 
subject: Unable to run Apache 2.x