This week's book giveaway is in the OO, Patterns, UML and Refactoring forum.
We're giving away four copies of Refactoring for Software Design Smells: Managing Technical Debt and have Girish Suryanarayana, Ganesh Samarthyam & Tushar Sharma on-line!
See this thread for details.
The moose likes Tomcat and the fly likes JK2 with IIS5 in WIn2000 sp4 not running Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Products » Tomcat
Bookmark "JK2 with IIS5 in WIn2000 sp4 not running" Watch "JK2 with IIS5 in WIn2000 sp4 not running" New topic
Author

JK2 with IIS5 in WIn2000 sp4 not running

Usera User
Greenhorn

Joined: Jul 13, 2005
Posts: 21
Hi,

I try to integrate Tomcat with IIS but the jakarta isapi filter cannot start up.

I used isapi_redirector2.dll and defined the workers2.properties as

[shm]
info=Scoreboard. Requried for reconfiguration and status with multiprocess servers.
file=anon

[channel.socket]
port=8009
host=localhost

# define the worker
[ajp13]
channel=channel.socket:localhost:8009

# Uri mapping
[uri:/*]
worker=ajp13:localhost:8009

The window registry is defined as following

[HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Jakarta Isapi Redirector\2.0]
"workersFile"="D:\\Server\\Apache\\Tomcat\\5.0\\conf\\workers2.properties"
"extensionUri"="/jakarta/isapi_redirector2.dll"
"logLevel"="debug"
"serverRoot"="D:\\Server\\Apache\\Tomcat\\5.0\\"

Has any idea?
 
I’ve looked at a lot of different solutions, and in my humble opinion Aspose is the way to go. Here’s the link: http://aspose.com
 
subject: JK2 with IIS5 in WIn2000 sp4 not running
 
It's not a secret anymore!