This week's book giveaway is in the Servlets forum.
We're giving away four copies of Murach's Java Servlets and JSP and have Joel Murach on-line!
See this thread for details.
The moose likes JBoss/WildFly and the fly likes Don?t understand the following LocalTxConnectionManager warning message. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Don?t understand the following LocalTxConnectionManager warning message. " Watch "Don?t understand the following LocalTxConnectionManager warning message. " New topic
Author

Don?t understand the following LocalTxConnectionManager warning message.

Tony Evans
Ranch Hand

Joined: Jun 29, 2002
Posts: 573
am currently setting up a MS SQL Server datasource.
I have carried out the following steps.
1 Modified the mssql-ds.xml:
<datasources>
<local-tx-datasource>
<jndi-name>jdbc/webconnect</jndi-name>
<connection-url>jdbc:microsoft:sqlserver://stl00895:1433;DatabaseName=webconnect</connection-url>
<driver-class>com.microsoft.jdbc.sqlserver.SQLServerDriver</driver-class>
<user-name></user-name>
<password></password>
</local-tx-datasource>
</datasources>
I added this file along with my JDBC driver jar mssqlserver.jar into the server directory I am using :
C:\jboss-3.2.0RC2_tomcat.4.1.18\server\default\deploy.
I then get the following warning message :
10:25:00,453 WARN [LocalTxConnectionManager]
Please change your datasource setup to use TransactionManagerService with object name jboss.tm:service=Transaction ManagerService instead of TransactionManager with value java:/TransactionManager
------------------------
10:25:00,453 WARN [LocalTxConnectionManager] ----------------------------------
I admit I do not know what this message means.
The jms-service.xml file contains the following line
<attribute name="TransactionManager">java:/TransactionManager</attribute>, but this is to do with JMS not datasource.
Do I need to add a similar line to my datasource file mssql-ds.xml:
Thanks for any help Tony
Darryl A. J. Staflund
Ranch Hand

Joined: Oct 06, 2002
Posts: 303
Hi Tony,
I don't know what it means either but it's just a warning and shouldn't affect your data connection. The warning is new as of JBoss 3.2 RC 2 and there's been a little discussion of it on jboss.org but nothing that really tells me whatr its about or how to rectify it.
I'll post a comment here if I find out more.
Darryl
Tony Evans
Ranch Hand

Joined: Jun 29, 2002
Posts: 573
I get the following error message when I run my application :
t.4.1.18/server/default/deploy/mssql-ds.xml
6:35:32,718 INFO [STDOUT] [WebConnect] Calling live service 'getShortcutBar()'
..
6:35:34,343 ERROR [STDERR] java.rmi.RemoteException: Unable to get shortcut DAO
Unable to get data source: Unable to get datasource for <jdbc/webconnect>: jav
x.naming.NameNotFoundException: jdbc not bound
my datasource mssql-ds.xml contains the following:
<datasources>
<local-tx-datasource>
<jndi-name>jdbc/webconnect</jndi-name>
<connection-url>jdbc:microsoft:sqlserver://stl00895:1433;DatabaseName=webconnect</connection-url>
<driver-class>com.microsoft.jdbc.sqlserver.SQLServerDriver</driver-class>
<user-name></user-name>
<password></password>
</local-tx-datasource>
</datasources>
Maybe I need to add a reference to jdbc in my jboss.xml

<?xml version="1.0" encoding="UTF-8"?>
<jboss>
<enterprise-beans>
<session>
<ejb-name>ShortcutManager</ejb-name>
<jndi-name>ejb/com/smartstream/webconnect/business/ejb/ShortcutManagerHome</jndi-name>
</session>
<session>
<ejb-name>DashboardManager</ejb-name>
<jndi-name>ejb/com/smartstream/webconnect/business/ejb/DashboardManagerHome</jndi-name>
</session>
<entity>
<ejb-name>Control</ejb-name>
<jndi-name>ejb/com/smartstream/webconnect/business/ejb/ControlLocalHome</jndi-name>
</entity>
<entity>
<ejb-name>Schema</ejb-name>
<jndi-name>ejb/com/smartstream/webconnect/business/ejb/SchemaLocalHome</jndi-name>
</entity>
<entity>
<ejb-name>Item</ejb-name>
<jndi-name>ejb/com/smartstream/webconnect/business/ejb/ItemLocalHome</jndi-name>
</entity>
</enterprise-beans>
</jboss>
Thanks for any help.
Tony
Carl Domingue
Greenhorn

Joined: Apr 12, 2004
Posts: 1
I finally figured out how to solve the "jdbc not bound" problem. It seems that JBoss is trying to lookup the jndi path in the global context, but the datasource is bound in the "java:" namespace.
After much digging, I resolved the problem by creating a link from the global namespace to the java namespace by adding the following to my oracle-ds.xml file:
<mbean code="org.jboss.naming.NamingAlias" name="jboss.jmx:alias=jdbc/fallout">
<attribute name="FromName">jdbc/fallout</attribute>
<attribute name="ToName">java:/jdbc/fallout</attribute>
</mbean>
I'm not sure about the "jboss.jmx:" part, don't know what that means, I copied the code from somewhere else. It works.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Don?t understand the following LocalTxConnectionManager warning message.
 
Similar Threads
Error during deploy; - nested throwable:(javax .naming. NamingException:
Urgent help needed : MS-SQL 2K DataSource Configuration
Configure to MS SQL Server 6.5
setting up MS SQL Server as a data source with JBoss
MySql and JBoss