aspose file tools*
The moose likes JBoss/WildFly and the fly likes jboss on windows 98 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "jboss on windows 98" Watch "jboss on windows 98" New topic
Author

jboss on windows 98

Varun Narula
Ranch Hand

Joined: Nov 19, 2001
Posts: 90
i need to run jboss-3.0.4_tomcat-4.1.12 on windows 98. but when i run the run.bat file thru the dos promt, it starts giving errors.
any help would be appreciated..


There are only 10 types of people in this world; those who understand binary and those who dont<p>Varun Narula <br />SCJP, SCWCD, IBM-486 (UML)
Darryl A. J. Staflund
Ranch Hand

Joined: Oct 06, 2002
Posts: 303
What kind of errors are you getting?
Varun Narula
Ranch Hand

Joined: Nov 19, 2001
Posts: 90
the run.bat file starts off with a syntax error but continues to run. somewhere halfway, a lot of exceptions are thrown and all the services get undeployed. a pipe to a txt file does not work
c:\run.bat > output so i am unable to provide exact outputs, however the run.bat file is as follows :

@echo off
rem -------------------------------------------------------------------------
rem JBoss Bootstrap Script for Win32
rem -------------------------------------------------------------------------
rem $Id: run.bat,v 1.4 2002/03/05 03:00:30 user57 Exp $
@if not "%ECHO%" == "" echo %ECHO%
@if "%OS%" == "Windows_NT" setlocal
set DIRNAME=.\
if "%OS%" == "Windows_NT" set DIRNAME=%~dp0%
set PROGNAME=run.bat
if "%OS%" == "Windows_NT" set PROGNAME=%~nx0%
rem Read all command line arguments
set ARGS=
:loop
if [%1] == [] goto endloop
set ARGS=%ARGS% %1
shift
goto loop
:endloop
rem Find run.jar, or we can't continue
set RUNJAR=%DIRNAME%\run.jar
if exist "%RUNJAR%" goto FOUND_RUN_JAR
echo Could not locate %RUNJAR%. Please check that you are in the
echo bin directory when running this script.
goto END
:FOUND_RUN_JAR
if not "%JAVA_HOME%" == "" goto ADD_TOOLS
set JAVA=java
echo JAVA_HOME is not set. Unexpected results may occur.
echo Set JAVA_HOME to the directory of your local JDK to avoid this message.
goto SKIP_TOOLS
:ADD_TOOLS
set JAVA=%JAVA_HOME%\bin\java
if exist "%JAVA_HOME%\lib\tools.jar" goto SKIP_TOOLS
echo Could not locate %JAVA_HOME%\lib\tools.jar. Unexpected results may occur.
echo Make sure that JAVA_HOME points to a JDK and not a JRE.
:SKIP_TOOLS
rem Include the JDK javac compiler for JSP pages. The default is for a Sun JDK
rem compatible distribution to which JAVA_HOME points
set JAVAC_JAR=%JAVA_HOME%\lib\tools.jar
set JBOSS_CLASSPATH=%JBOSS_CLASSPATH%;%JAVAC_JAR%;%RUNJAR%
rem Setup JBoss sepecific properties
set JAVA_OPTS=%JAVA_OPTS% -Dprogram.name=%PROGNAME%
set JBOSS_HOME=%DIRNAME%\..
rem JPDA options. Uncomment and modify as appropriate to enable remote debugging.
rem set JAVA_OPTS=-classic -Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,address=8787,server=y,suspend=y %JAVA_OPTS%

echo ===============================================================================
echo .
echo JBoss Bootstrap Environment
echo .
echo JBOSS_HOME: %JBOSS_HOME%
echo .
echo JAVA: %JAVA%
echo .
echo JAVA_OPTS: %JAVA_OPTS%
echo .
echo CLASSPATH: %JBOSS_CLASSPATH%
echo .
echo ===============================================================================
echo .
%JAVA% %JAVA_OPTS% -classpath "%JBOSS_CLASSPATH%" org.jboss.Main %ARGS%
:END
if "%NOPAUSE%" == "" pause
:END_NO_PAUSE
Martin Sergeant
Greenhorn

Joined: May 20, 2003
Posts: 24
I had similar problems too. The problem line seems to be:
set JAVA_OPTS=%JAVA_OPTS% -Dprogram.name=%PROGNAME%
If you remove this line (or rem it out) and change this line:
"%JAVA%" %JAVA_OPTS% -classpath "%JBOSS_CLASSPATH%" org.jboss.Main %ARGS%
to
"%JAVA%" %JAVA_OPTS% -Dprogram.name=%PROGNAME% -classpath "%JBOSS_CLASSPATH%" org.jboss.Main %ARGS%
everything should be fine.
You need to SET JAVA_HOME=c:\j2sdk1.4.1_03 or to where ever your SDK is and ensure you have enough environment space.
Also it will not work with sdk 1.3 but will with sdk 1.4- I(I have not tried any of the in-between versions).
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: jboss on windows 98
 
Similar Threads
SCEA and Windows 98
Which version of Tomcat.......
Bea web logic
Tomcat installation help please!!!!!
Which Version Of JBoss Should I Use?