This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes JBoss/WildFly and the fly likes Servlet not working Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Servlet not working" Watch "Servlet not working" New topic
Author

Servlet not working

Arun Shanmugham
Greenhorn

Joined: Oct 06, 2003
Posts: 15
Hi All,
I wanted to port an application from Tomcat to JBoss. I copied the war file from tomcat to JBoss. I was getting error in executing the servlet from JBoss . Then i just created a simple application with 1 servlet in new.war file which has the following structure
/Test.html
/WEB-INF/classes/com/servlet/TestServlet
/web.xml (this maps com.servlet.TestServlet to Test)
When i tried http://localhost/new/Test.html it works.
When i tried http://localhost/new/servlet/Test it does'nt work and
the error from JBoss-Tomcat is "404 requested resource not found(new/servlet/Test).
Do u have any idea why its not working..?
Arun


Technical Architect (SCJP)
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Servlet not working
 
Similar Threads
JBoss and Tomcat Error
TOMCAT error
Servlet is not displaying
servlet configuration problem
Servlet not working