aspose file tools*
The moose likes JBoss/WildFly and the fly likes Forcing local dtds Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Forcing local dtds" Watch "Forcing local dtds" New topic
Author

Forcing local dtds

Lallero Lallero
Greenhorn

Joined: Mar 08, 2004
Posts: 2
Hi all,
I'm using jboss 3.2.3 and I'm trying to deploying an ear in Jboss. All goes well if the machine with jboss is connected to internet, but if not xerces tries to download the needed dtd during the deploy, throwing a "connection timeout" error. I've read that you can eliminate DOCTYPE from xml descriptor in ear, but for us in not an option. Is there a way to force the use of local dtds without changing the DOCTYPE of every xml in ear?
Thanks in advance.
Adam Hardy
Ranch Hand

Joined: Oct 09, 2001
Posts: 566
JBoss uses a dtd cache, but if your DTD isn't one of the recognised DTD which it caches, then it will always go to the net, or try to.
THere's a whole list of which DTDs JBoss caches, hard-coded in JBossEntityResolver.java.


I have seen things you people would not believe, attack ships on fire off the shoulder of Orion, c-beams sparkling in the dark near the Tennhauser Gate. All these moments will be lost in time, like tears in the rain.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Forcing local dtds