Win a copy of Design for the Mind this week in the Design forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Cannot seem to set JK2 LogLevel in Integrated Tomcat

 
Aaron Beverly
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello:
I cannot seem to get rid of all the DEBUG level log messages from the JK2 connector I have setup between Apache 2 and the integrated Tomcat container in JBoss 3.2. I have set all of the debug directives in the various loggers to 0 and I have included a JkLogLevel info in my httpd.conf.
My setup is as follows:
I have three instances of Tomcat 4 running, with a separate ajp13 connector for each; two of these instances are stand-alone tomcats, with loadbalancing enables. The third is the integrated tomcat that comes bundled with JBoss. Everything is set up, everything works, the connectors work fine, load-balancing works fine. However, in the Integrated instance of Tomcat running in the JBoos server, I am getting all of the JK2 debugging log messages and I cannot seem to turn them off. I do not get these messages in either of the other two instances of tomcat.
Is there something special I need to do get rid of these things? They are really bogging down the application and bloating the server logs.
Thanks in advance,
Aaron
 
Adam Hardy
Ranch Hand
Posts: 567
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are you configuring the log4j settings in JBoss/server/default/conf/log4j.xml?
Try putting in something like:
 
Aaron Beverly
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ah, you are onto something. I had to add
<category name="org.apache.jk">
<priority value="INFO" />
</category>
to conf/log4j.xml
Thanks for the help!!
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic