*
The moose likes JBoss/WildFly and the fly likes Jboss and MS Access Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Jboss and MS Access" Watch "Jboss and MS Access" New topic
Author

Jboss and MS Access

Saman Perera
Ranch Hand

Joined: Jul 15, 2003
Posts: 61
Hi all

I try to configure the Jboss AS 3.2.6 and MS Access DB from the eclipse and JbossIDE

I use the following file as MSAccess-DS.xml but the hsqldb-ds.xml also the


<?xml version="1.0" encoding="UTF-8"?>

<!-- ===================================================================== -->
<!-- -->
<!-- JBoss Server Configuration -->
<!-- -->
<!-- ===================================================================== -->

<!-- $Id: msaccess-ds.xml,v 1.1 2002/07/22 22:57:24 d_jencks Exp $ -->
<!-- ==================================================================== -->
<!-- This uses the sun jdbc-odbc driver, so don't expect miracles -->
<!-- Thanks to Alan Moor, who warns... -->
<!-- Remember, though, never trust critical data, or data that you can't -->
<!-- afford to lose, or data that you need quick access to, or data that -->
<!-- needs to be secure, to Microsoft Access. -->
<!-- ===================================================================== -->


<datasources>
<local-tx-datasource>
<jndi-name>MSAccessDS</jndi-name>
<!-- format of URL is "jdbc dbc SNNAME" -->
<connection-url>jdbc dbc:saman</connection-url>
<driver-class>sun.jdbc.odbc.JdbcOdbcDriver</driver-class>
<user-name>x</user-name>
<password>y</password>
</local-tx-datasource>

</datasources>


I created a Entity bean ,it was deployed but the following exception is occured


09:00:10,688 INFO [EARDeployer] Init J2EE application: file:/C:/jboss-3.2.6/server/default/deploy/Pro-EAR.ear
09:00:11,093 INFO [EjbModule] Deploying Test
09:00:13,278 INFO [EJBDeployer] Deployed: file:/C:/jboss-3.2.6/server/default/tmp/deploy/tmp24406Pro-EAR.ear-contents/Pro_EJB.jar
09:00:13,388 INFO [EARDeployer] Started J2EE application: file:/C:/jboss-3.2.6/server/default/deploy/Pro-EAR.ear
09:00:13,403 ERROR [URLDeploymentScanner] Incomplete Deployment listing:
Packages waiting for a deployer:
org.jboss.deployment.DeploymentInfo@88d0fb19 { url=file:/C:/jboss-3.2.6/server/default/deploy/MSAccess-DS.xml }
deployer: null
status: null
state: INIT_WAITING_DEPLOYER
watch: file:/C:/jboss-3.2.6/server/default/deploy/MSAccess-DS.xml
lastDeployed: 1123038013388
lastModified: 1123038013388
mbeans:

Incompletely deployed packages:
org.jboss.deployment.DeploymentInfo@88d0fb19 { url=file:/C:/jboss-3.2.6/server/default/deploy/MSAccess-DS.xml }
deployer: null
status: null
state: INIT_WAITING_DEPLOYER
watch: file:/C:/jboss-3.2.6/server/default/deploy/MSAccess-DS.xml
lastDeployed: 1123038013388
lastModified: 1123038013388
mbeans:


09:00:13,872 INFO [Http11Protocol] Starting Coyote HTTP/1.1 on http-0.0.0.0-8080
09:00:14,293 INFO [ChannelSocket] JK2: ajp13 listening on /0.0.0.0:8009
09:00:14,293 INFO [JkMain] Jk running ID=0 time=0/94 config=null
09:00:14,340 INFO [Server] JBoss (MX MicroKernel) [3.2.6 (build: CVSTag=JBoss_3_2_6 date=200410140106)] Started in 24s:425ms


please help me

thanking u
saman
SCJP 1.4
Sanju Thomas
Ranch Hand

Joined: Dec 29, 2004
Posts: 243
You need to add an entry in the standardjobsscmp-jdbc.xml to configire access datasource to JBoss.

In the standardjbosscmp-jdbc.xml set

<jbosscmp-jdbc>
<defaults>
<datasource>java:/MSAccessDS</datasource>
<datasource-mapping>MS ACCESS</datasource-mapping>
</defaults>
</jbosscmp-jdbc>

Try it out, may help you.
 
 
subject: Jboss and MS Access
 
Similar Threads
Error whiling running the server
Jboss deployment error - help for a beginner
Jboss Server
Error while deploying
new to jndi name connecting to mysql